NAS540: No volume label after deletion of sysvol-1

masterflai
masterflai Posts: 19  Freshman Member
edited January 2018 in Personal Cloud Storage
Hello everyone, I made a big mistake today. I wanted to install a new hard disk and found a disabled share sysvol-1 in the shares section. Since there was an active sysvol share, I deleted the disabled share correctly with confirmation via "DELETE".

But now the volume name of my main disk is no longer recognized after the restart. The hard disk does not get a volume name.

It was previously listed under /i-data/2888f87b and was called Volume2.

There was a share on the hard disk called "Daten".

All hard disks are created as "basic" volume. No RAID.

Do you have any idea how to correct the drive so that the share is displayed again?

#NAS_December

All Replies

  • klcko001
    klcko001 Posts: 7  Freshman Member
    Hello, I have the same problem, Have you found any solution? https://homeforum.zyxel.com/discussion/1652/nsa310s-predefined-shares-without-disk-value#latest

    Thank you  
  • Mijzelf
    Mijzelf Posts: 1,630  Guru Member
    edited October 2018
    On the NAS540 the correct answer was
    <div>su<br></div><div>echo "Some Volume Name" >/i-data/sysvol/.system/name_label</div><div><br></div><div>reboot</div><div></div>
    when I remember well. Don't know if that also applies for a NSA310s, but it won't hurt.

    You can use the Telnet backdoor for that.
  • masterflai
    masterflai Posts: 19  Freshman Member
    I wasn't able to solve the problem. So finally I decided to choose the data from my backup, so one day data was lost.
  • masterflai
    masterflai Posts: 19  Freshman Member
    Today I got a similar problem after the change of the master drive with the following guide:

    The problem was, that after the execution of the named commands, there were two drives with identical letters. Which makes sense, cause I copied the contect if the .system folder to an existing disk which should be the new admin disk.

    </code><code>cp -a /i-data/sysvol/.system /i-data/<HEXVALUE>/
    I found no solution for this, so I decided to get back and I delete the .system folder on the new drive, changed back the symlink for sysvol, but the letter for the disk was empty.

    The solution is as simple, as mijzelf wrote above, but it's important to change it a little bit, if the drive with the missing Volume name isn't the system drive.

    Choose the correct drive in /i-data/ and execute the command by using the correct drive name:

    <code><HEXVALUE>/.system/name_label
    reboot</code><code>su<br>echo "Some Volume Name" >/i-data/
    A further option if the midnight commander is installed. Go to /i-data/ choose the disk with the missing Volume label. There shouldn't be a file name_label or if it exist, you can edit it.

    I copied the .system folder from another disk and edited the file name_label afterwards. There is just the name of the Volume in it.








Sign In to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click on this button!