[NAS326] Introduction and some file system problems

stepseldinski Posts: 3  Freshman Member
edited January 2018 in Personal Cloud Storage
Hi guys, after two days of fighting with my new NAS i need some help that google couldn't provide me so far.

But first things first. I am Steffen, 33 from Germany,  and my goal was a home network storage with cloud functionality. But as easy as I expected that it could be, as difficult it was in the end with a dramatic problem.

First I wanted to use my WD Mybook external drive to stream videos and pictures to my tv and other devices. But the folder functions didnt work out without inizialization of at least one bay. So I took all my single external drives to shift all data away from my one 1TB drive, to use it as the main drive in a bay. Because of filesystem change I had to shift. So I used a 320 gb hdd in bay 1, formated it as ext4 and copied all my pictures from the 1tb hdd on it. After the 1tb hdd was empty, I put it into bay 2 and formated it as basic raid. So good so far. I could access all my pictures. In the evening I switched the NAS off.

Next day, I tried to get my 1 tb drive as a single volume in the NAS. Was playing around with the iSCSI option. Provided all the 1tb to that LUN. Never touched the first drive with my pictures.

Then there was a moment, when I couldnt access my NAS anymore. Browser was showing only the blue background. Login took forever or was only showing the blue background. Multiple reboots didnt help. Only a reset of the NAS brought me back to the UI. And there it was showing:

HDD in bay 1 down. It was showing not just down but also 100 percent full.
No access anymore. And no filesystem.

I tried to put it into an external case to access it directly from my Mac somehow. But it couldnt recognize the filesystem as well. In the hdd manager it shows that it is a raid format. It showed three partitions on it. 2,05 gb; 2,05 gb; and the 3xx gb as the rest. Is there a possibility for me to repair the filesystem? I downloaded the Paragon extfs. But it couldnt access.

Every help would be apriciated! And sorry for the long text. I try to be accurate.



All Replies

  • Wiasouda
    Wiasouda Posts: 156  Master Member
    Hi Steffen,
    It is weird as you create LUN with all 1TB for bay 2, but bay 1 is full....
    Is the 320G HDD health? How long has the HDD used?
    You can attach some photos, maybe some expert user would know how to provide you the assistance..
  • stepseldinski
    stepseldinski Posts: 3  Freshman Member
    Hi, thanks for the answer. After many days of searching the net, I think I am a bit wiser now. 

    My problem seems to be that I created the volumegroup with the 250gb and 1tb later. And then I took that 1tb out of the group. So the group seems to be incomplete now. Or degraded as it seems to be called.

    Zyxel has a workaround for such cases, but it didnt work for me until now. That one: 


    I tried a lot to understand what it happening there but failed. 

    What I think to know: 

    As I created a volume group out of volumes, I created a JBOD with a basic Raid mode. The group is called md0. I didnt touch the partitions of my 250gb disk. fdisk -l shows

    sdc1   1,9gb   type: Linux RAID
    sdc2   1,9gb   type: Linux RAID
    sdc3  229gb   type: Linux RAID

    In the description of zyxel it is written to assemble the HDD: JBOD, degraded RAID1:
    mdadm -A -f /dev/md0 /dev/sda2

    For me this looks like I am creating a volume group md0 with the partition sda2

    In my case it would be sdc2, right? This I did. After checking again with cat /dev/mdstat it showed:

    md0: active raid sdc2 [ 0 ]
             xxx blocks super 1.2 [2/1] [U_]

    For me that means that only the partition sdc2 with 1,9gb is taken into the md0 group, right?
    And the underscore is showing that a second disc or partition is missing. 

    Could someone explain me how to access the data on this disk again? Do I have to expand the group again? Or is there a way to see my data from this disk directly? 

  • Wiasouda
    Wiasouda Posts: 156  Master Member
    Hi, unfortunately, JBOD and Basic RAID doesn't have the recovery mechanism to restore data, and the file system of 2 HDDs now is broken, that NAS can't indentify the data correctly, so my point of veiw is that get your data back..., might not possible.

  • stepseldinski
    stepseldinski Posts: 3  Freshman Member
    Hi, thanks for the answer.

    Not so nice news. I will try further but with less expectations. If I will find a way, I will post it.

Consumer Product Help Center