URGENT: Can't upgrade to new Multy X Firmware V2.00(ABKJ.1)CO

Shayan
Shayan Posts: 4  Freshman Member
edited April 2018 in Multy WiFi System
I have the Multy X System. I've got the latest app version downloaded. But I cannot seem to upgrade to the latest firmware V2.00(ABKJ.1)CO via the app. It keeps saying Firmware upgrade failed try again. Must have tried 10 times. I've even restarted my entire system. How do I upgrade to the latest firmware? Is there a downloadable file and a way to manually update this via Ethernet??? I'm doing this on an iPhone X. Why is this so difficult and how can you sys release a firmware upgrade without thoroughly testing the same!!!? In these situation Eero, Linksys, Netgear all offer direct firmware upgrades via ethernet. Surely the Multy X team have thought of this and created a back door when the app update fails????

#MultyX_March
«1

Comments

  • rsr
    rsr Posts: 2  Freshman Member
    Sorry to hear that you are having a problem. Just for info, I upgraded my Multy X set this morning via my iPhone 8 Plus (iOS 11.2.6). It worked like a dream! I downloaded the updated app and as soon as it started was informed that new firmware was available. The update took no more than five minutes.

    I would hesitate to compare the Multy X with Netgear’s Orbi. One huge advantage of Zyxel’s approach is that the kit actually works! I started out with the Orbi and was pleased to exchange for the Multy X after countless issues. One look at Netgear’s Orbi forum and you will see that after several months and literally hundreds of messages from disappointed users, a good number still suffer intermittent problems.

    i hope someone from Zyxel will be able to solve your issue.
  • Leon
    Leon Posts: 1  Freshman Member
  • Hill
    Hill Posts: 154  Master Member
    It seems fine now. Try again. ;)

  • Hanamichi
    Hanamichi Posts: 125  Ally Member
    May I know do you upgrade APP to the latest version?
    And does the problem still exist? Is there any screenshots?
  • Vivicat
    Vivicat Posts: 3  Freshman Member
    @Leon

    我update一次就成功了~要不要再試看看?



  • Shayan
    Shayan Posts: 4  Freshman Member
    Yes its sorted now. The firmware updated magically. lol!
  • Hao
    Hao Posts: 1  Freshman Member
    edited April 2018
    I have the same issue here, have internet but there is fail on update for 2 days...
    is that an problem on oversea in Philippines update Multy X
    (I get 2 set in Taiwan working fine, but Philiipines is my first see this happening)

    Can I update via different platform, such as webUI or otherway
    because on site on can download the firmware but don't know how to do it
  • Zyxel_Steven
    Zyxel_Steven Posts: 247  Zyxel Employee
    In order to provide you with a better assistance, we have contacted you via private message. Please kindly check your message box.
  • MrG
    MrG Posts: 1  Freshman Member
    I have the exact same problem - just completed setup 2 boxes and get a msg that FW is outdated, update now. After a few minutes I just get > FW update failed > retry or remind me later.
    Reset box, same issue. !!

    Very annoying this. Please advice. Everything seems to be running apart from this.
  • Zyxel_Steven
    Zyxel_Steven Posts: 247  Zyxel Employee
    In order to provide you with a better assistance, we sent you a private message.
    Please kindly check your message box. :)

Consumer Product Help Center