WordPress Update for NSA325

Laserjunge Posts: 3  Freshman Member
edited May 2018 in Personal Cloud Storage
Dear all,

after days of searching for a solution, first to update the WordPress Package of my NSA325v2, and then second, to repair the reoccurring forbidden error, I thought to contact you guys for help.

Here a short description, what I have done so far:

My way to update the WordPress package v3.6 of Zyxel NSA 325v2:
1 Install Wordpress 3.6 via the Package install page in the system settings of the Zyxel server 
2 Go to the Wordpress page, create a second administrator (Wordpress >4.0 has no admin user anymore)
3 Download the Updater plugin v.1.26 by BestSoftWeb (https://wordpress.org/plugins/updater/advanced/). Do not install the recent version of the Updater via the WordPress plugin page since the newer versions use a cookie to mark your server system as not appropriate (require WP version 3.9 minimum). Unzip and copy the downloaded folder 'updater' to /admin/zy-pkgs/Wordpress/plugins/
4 Go to the Wordpress page, activate the Updater plugin, and update WP to the newest version 
5 Wait minutes/hours (?) and update the database via http://NSA-url/pkg/WP-admin/upgrade.php
From the moment of the database update, I could use WordPress 4.9 for hours to install/edit recent themes, upload images, create galleries, create posts/pages, change the setting (time format, page title), backup the database and everything for suddenly not being able to access ANY content anymore. Whatever page I tried to access, frontend or backend (wp-admin), I always got

You don't have permission to access /adv,/pkg/WordPress/ on this server."

I found that only deleting the WP installation files from the server helped in the sense that I was able to regain access to WP after reinstallation. For that, my procedure was as follows:
1 Install and activate the SSH package in the system settings of the Zyxel server 
2 Deinstall WP package in the system settings of the Zyxel server 
3 Use the terminal/command line tool to login to the server via SSH protocol
4 Delete the folder /usr/local/zy-pkgs/gui/WordPress
5 Deactivate SSH on your server. 
6 Install the WP package (v3.6) in the system settings of the Zyxel server 
7 Update WP to the newest version as described above
The cool thing is, the main content (posts, pages, images) remain on the server as long you do not delete the WordPress files, which you can find in the admin/zy-pkgs/WordPress folder via smb/ftp.

However, here the problem: Whatever I do, the Forbidden error occurs again and again always under different circumstances. 

Sometimes when I install a plugin or change its setting, or when I changes the WP general settings. So, seemingly standard operations. I avoided to install the W3 total cache plugin (which is known for causing htaccess cracks), any plugin to restrict user rights (which could manipulate the htaccess, too). Last time, I really only updated WP (v4.9) and installed just a single theme (without updating/installing additional plugins as I did before) just doing standard operations in the backend such as uploading images, creating pages and everything worked out fine, until I changed the permanent link settings (another "standard" operation from my point of view which works under WP v3.6) and zack... Forbidden errors all over the place.

Does anybody see a reason for this? Why is this happening on my Zyxel system?
Any help is appreciated. 



  • Ijnrsi
    Ijnrsi Posts: 254  Master Member
    HI, I tried this directly with v4.9 with web publishing, then I got a error as V4.9 is requiring MySQL v3.6, but current version of mysql from APP center is 3.5.6, so the application would not work.
    I guess this might be one of reason and the wordpress package from APP center was already modified by Zyxel, so the config might be different as default.

Consumer Product Help Center