New Shared Folders Won't Accept Uploads

10TonTurtle Posts: 4  Freshman Member
edited May 2018 in Personal Cloud Storage

Currently I've got my NAS to only accept uploads through the browser-based file manager; can't add anything from my PC (which I see as a good thing, as viruses, worms, and other nasty stuff can't just upload themselves straight to it and hide there), just through the NAS's file browser. I've made several custom shared folders in the past with no issues.

My problem now is that, while I can upload things to currently-existing shared folders, any new shared folders I make won't accept any uploads. I've tried going into Control Panel and editing the privileges so that the new folders should work, but they still won't. Any folders I make within them simply don't exist outside of the directory tree; as soon as I click into and out of them, they cease to exist. This seems to have started since at least the last firmware update (current version 5.21).



Accepted Solution

  • 10TonTurtle
    10TonTurtle Posts: 4  Freshman Member
    edited June 2018 Answer ✓
    After much fiddling with PowerShell, I can confirm that yes, admin shows in the "valid users" line. And I can, after connecting with the "admin" account, add/delete files from every other folder except for "dnd" (the new shared folder) from the PC as well. I just checked. So no change yet. :disappointed:

    EDIT: Just tried deleting (completely deleting, not just "deactivating") the "dnd" shared folder and remaking it. No change.

    Removed the permissions for the 'everyone' Group. It works.
    Apparently the "everyone" Group includes the 'admin' account, and there's no way to remove that (or to move the 'admin' account from there), so having that checked can/will override everything else.

    So glad it was something so simple (and silly!) and not something deeper than that!

All Replies

  • Ijnrsi
    Ijnrsi Posts: 254  Master Member
    Hi @10TonTurtle
    Do you try to use CIFS/SMB to upload file in your PC?
    If yes, did you use the same user account to access the shared folder on your PC? Or you use different account and the account doesn't have the privilege to access the folder?
    If you setup the two different account then you may log out the previous one and change another account to log in.
  • 10TonTurtle
    10TonTurtle Posts: 4  Freshman Member
    ADDENDUM: Don't know how much help it'll be, but I forgot to mention that I have a model NAS540 device, FW v5.21.

    I've been using the same account (the base admin account) the entire time. Not the best decision security-wise, I know, but it's a personal NAS only set up to work from within the home. The admin account should has full access to everything on the NAS; I've checked several times, and even removed/re-added these permissions several times. I only use the File Browser app on the NAS's homepage to upload files.

    Once again, existing shared folders (folders made before this issue cropped up or that existed when initial setup completed) work as intended; I can add/delete files in them without issue.

    Any new shared folders that are created, however, are unusable, and will not retain new subfolders nor accept uploads through the File Browser (in shared or subfolders). Adding files directly from the PC (ie - click and drag) has been blocked for safety/security reasons.

    At least this issue only affects new shared/subfolders; if it somehow blocked upload access to existing folders, my backup plan would be in tatters!

  • Ijnrsi
    Ijnrsi Posts: 254  Master Member
    I think you can telnet to your NAS and use the command "cat /etc/samba/smb.conf" to check if the folder is allowed admin with full privilege or read only.

    Moreover, as I know Samba is default on and no way to disable, do you manually stop the SMB daemon or manually disable SMB feature on your PC?
    If you didn't change any setting, then you no possible to use SMB with your PC explorer, then met the problem, that I would guess that your configuration might got error, maybe need to reset it?

Consumer Product Help Center