NSA320 firmware and packages

cheese
cheese Posts: 1  Freshman Member
edited August 2018 in Personal Cloud Storage
It seems support terminated after V4.70(AFO.3).  
"Check for firmware" and "retrieve package list" do not work any more.  
What's the official recommendation of usage from this point?  Any place to manually download packages, or usage of FW/PKG of another model?  
#NAS_Aug

All Replies

  • Ijnrsi
    Ijnrsi Posts: 254  Master Member
    Hi, 
    You can download here.
    ftp://ftp.zyxeltech.de/2.new_mirror/NSA320/

  • Hi, I know I'm a little late here but I tried to access that link but I don't know what the username and password combo is?
  • Dexter
    Dexter Posts: 108
    First Comment Friend Collector Fourth Anniversary
     Ally Member
    edited October 2021
    Do you meet some problem that need to use the latest firmware?

  • Yes, every so often I lose connectivity with the NAS and it forces me to reboot it. 
  • Dexter
    Dexter Posts: 108
    First Comment Friend Collector Fourth Anniversary
     Ally Member
    You can check if there is any ip address conflict in your network.
    You can also try reset IP address on the NAS.
    Press the reset button until you hear one beep (after about two seconds), then release it. You will hear one more beep after you release the button. This resets the NAS's IP address and password to the default values. Don't worry, it won't delete the date on the NAS.

  • Mijzelf
    Mijzelf Posts: 2,137
    100 Answers 1000 Comments Friend Collector Fifth Anniversary
     Guru Member

    But I don't think your problem is firmware related. It has worked for years, and isn't changed.


  • The weird thing here is I could ping the NAS as that I have a static IP on it but could not reach it with the app/Web. This tells me the network stack is fine but the upper layer programs are not responsive.  
  • Mijzelf
    Mijzelf Posts: 2,137
    100 Answers 1000 Comments Friend Collector Fifth Anniversary
     Guru Member
    First thing which comes into my mind is either a package you installed which is causing problems, or a hardware error which crashes the backend when trying to generate a status report.
    If it was the package, I think you would have reverted it, so let's go for the hardware error.
    Do you have shell access? If not, try the Telnet backdoor. If you have got access, reboot the NAS, open a shell, run 'dmesg -c'. Then try to access the webpage, and if that fails, run 'dmesg'. There might be something pointing to bad hardware.

Consumer Product Help Center