Mount external USB drive on NSA310

Options
PaulF
PaulF Posts: 4  Freshman Member
edited October 2018 in Personal Cloud Storage
Hi, I have a USB portable hard drive with an NTFS and ext4 partitions. I'd like to use the ext4 partition for backup of my NSA310, using rsync. The NTFS parition is visible/mounted, but I can't get the ext4 partition mount. I'd appreciate any advice/pointers on how to do this.

The NTFS partition is sdb1 (label verb_ntfs), ext4 is sdb2 (label verb_ext4) and sda is the internal drive of the NSA310. Output of various commands below. Tried to attach it to a new directory in /mnt...

Thanks in advance/Paul

admin@nsa310:~$ cat /proc/partitions
major minor  #blocks  name

   7        0     139264 loop0
  31        0       1024 mtdblock0
   8        0  976762584 sda
   8        1     514048 sda1
   8        2  976245952 sda2
  31        1        512 mtdblock1
   .  .  .
   9        0  976244928 md0
   8       16 1709326582 sdb
   8       17 1228800000 sdb1
   8       18  480525312 sdb2
admin@nsa310:~$ sudo blkid
/dev/loop0: UUID="73858854-5baf-48c8-ae04-a898b8f904a7" TYPE="ext2"
/dev/sda1: UUID="8bf2f209-a76f-4cc8-af15-4b6325b3e953" TYPE="ext2"
/dev/md0: UUID="30327c42-7472-4281-950b-6f2f5ed5f045" TYPE="ext4"
/dev/sdb1: UUID="68DC8228485FAD77" TYPE="ntfs" LABEL="verb_ntfs"
/dev/sdb2: UUID="d510ecd2-52b1-424b-9ae1-c830248fd99e" TYPE="ext4" LABEL="verb_ext4"
admin@nsa310:~$ sudo fdisk -l

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x6f6d65c9

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1          64      514048+   8  AIX
/dev/sda2              65      121601   976245952+  20  Unknown

Disk /dev/sdb: 1750.3 GB, 1750350419968 bytes
255 heads, 63 sectors/track, 212801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x1bd0feb2

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1      152979  1228800000    7  HPFS/NTFS
/dev/sdb2          152979      212802   480525312   83  Linux

admin@nsa310:~$ mkdir -p /mnt/mountpoint
admin@nsa310:~$ sudo mount -o ro /dev/sdb2 /mnt/mountpoint
Password:
mount: wrong fs type, bad option, bad superblock on /dev/sdb2,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so
admin@nsa310:/mnt/mountpoint$ mount
. . .
/dev/sdb1 on /e-data/6e998211b7d9934b7193c867ea922892 type tntfs (rw,relatime,uid=99,gid=0,umask=00,nls=utf8,case_sensitive,nocache,errors=continue,mft_zone_multiplier=1)

#NAS_Oct_2018

Accepted Solution

  • Mijzelf
    Mijzelf Posts: 2,638  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Answer ✓
    Options
    Here is your problem:
    JBD: Unrecognised features on journal
    Your ext4 filesystem is 'too new'. Maybe you can mount it if you disable the journal on another linux box. (And maybe re-enable it from the NAS)
    The command to disable it is
    <pre class="CodeBlock"><code>tune2fs -O ^has_journal /dev/whateverAnd I *think* you can re-enable it using
    <pre class="CodeBlock"><code>tune2fs -O has_journal /dev/whatever
    But I don't know if the tune2fs on the NAS can do that.






All Replies

  • Mijzelf
    Mijzelf Posts: 2,638  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options
    I wouldn't be surprised if that old box doesn't support ext4. You can check that with
    <div>cat /proc/filesystems</div>

  • PaulF
    PaulF Posts: 4  Freshman Member
    Options
    Thanks, Mijzelf. From the output of the command you suggested, I think ext4 is supported:

    admin@nsa310:~$ cat /proc/filesystems<br>nodev&nbsp;&nbsp;&nbsp; sysfs<br><snip><br>nodev&nbsp;&nbsp;&nbsp; devpts<br>&nbsp;&nbsp;&nbsp; reiserfs<br>&nbsp;&nbsp;&nbsp; ext3<br>&nbsp;&nbsp;&nbsp; ext2<br>&nbsp;&nbsp;&nbsp; ext4
    Thnaks/Paul


  • Mijzelf
    Mijzelf Posts: 2,638  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    edited October 2018
    Options
    OK. The error mount (actually busybox) spawns is a catch all. It just says 'failed'. Further it will try all filesystems, until one fits, cluttering the logs.

    So try
    <div>mount -t ext4 -o ro /dev/sdb2 /mnt/mountpoint</div><div><br></div><div>dmesg | tail<br></div>
    to see what is going wrong.

    BTW, where did you get sudo from?
  • PaulF
    PaulF Posts: 4  Freshman Member
    Options
    Thanks again for sticking with this, Mijzelf.
    admin@nsa310:/$ dmesg | tail<br>tntfs error (device sdb2, pid 3025): read_ntfs_boot_sector(): Mount option errors=recover not used. Aborting without trying to recover.<br>tntfs error (device sdb2, pid 3025): ntfs_fill_super(): Not an NTFS volume.<br>uncorrectable error : <br>end_request: I/O error, dev mtdblock7, sector 20352<br>Buffer I/O error on device mtdblock7, logical block 2544<br>end_request: I/O error, dev mtdblock7, sector 20352<br>Buffer I/O error on device mtdblock7, logical block 2544<br>EXT4-fs (sdb2): barriers enabled<br>JBD: Unrecognised features on journal<br>EXT4-fs (sdb2): error loading journal
    Regarding sudo - I installed a package of utilities, which added a number of useful commands & functions (including rsync) that I found on the old NAS central forum - I think this may even have originated from you (?) - suspect that this may also have added sudo.  

    Thanks/paul
  • Mijzelf
    Mijzelf Posts: 2,638  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Answer ✓
    Options
    Here is your problem:
    JBD: Unrecognised features on journal
    Your ext4 filesystem is 'too new'. Maybe you can mount it if you disable the journal on another linux box. (And maybe re-enable it from the NAS)
    The command to disable it is
    <pre class="CodeBlock"><code>tune2fs -O ^has_journal /dev/whateverAnd I *think* you can re-enable it using
    <pre class="CodeBlock"><code>tune2fs -O has_journal /dev/whatever
    But I don't know if the tune2fs on the NAS can do that.






  • PaulF
    PaulF Posts: 4  Freshman Member
    Options
    Thanks very much, Mijzelf - I'm trying it out now - bit of finger trouble turning the journal off, but will keep trying.

Consumer Product Help Center