Connection failed NAS326

MrAnderson1 Posts: 2  Freshman Member
First Anniversary
edited January 2019 in Personal Cloud Storage
Hi, i'm writing because my new nas, unboxxed 30 minutes ago doesn't connect to the wifi. I followed every single step but at the time i have to press the button within 5 minutes nothing happen and the timer still running. I tried with phone, notebook, desktop pc, i tried to change the ethernet cable, nothing. 


All Replies

  • Wiasouda
    Wiasouda Posts: 156  Master Member
    How did you connect your NAS326 to router? NAS326 doesn't support wireless connection, you should use ethernet cable to connect NAS326 and router.
    Moreover, you can also use http://nas326/ in your address bar to access NAS326 or check your client list (IP table) in your router management page.
    If no change, try to reset it by pressing reset button, press and hold the button till you hear 3 beeps and wait for 5 minutes, then you will hear continue beeps and NAS326 start to reset and reboot, then to try again.

Consumer Product Help Center