Entware-ng on NAS326 (3rd party zypkgs)

Options
alfaalfa
alfaalfa Posts: 6  Freshman Member
First Anniversary
edited February 2019 in Personal Cloud Storage
I'm newbie here. I wanted to install Entware-ng using Meta Repository. Unfortunately after installation I was not able to use it normally. I have to do manually after each reboot:
PATH=$PATH:/opt/bin:/opt/sbin
export PATH
Then it seems to work. My question to you guys is: where/how to place a script in order to run these commands on boot. I have tried to put a shell script in /i-data/.system/zy-pkgs, but it seems not to be executed there. In system (e.g /etc/profile) folders its impossible to edit/save files. Probably a script to modify /etc/profile on boot is a better choice, but again, where/how to place it? Thank you in advance for help!

#NAS_Feb_2019

Accepted Solution

  • Mijzelf
    Mijzelf Posts: 2,638  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Answer ✓
    Options
    You should install package profile-hook . It should be installed at setup, but maybe the server was not accessible?

All Replies

  • kempiude
    kempiude Posts: 6  Freshman Member
    Options
    You need to check this two files:
    /opt/etc/init.d/S99ProfileHook
    /opt/etc/profile

    In the /opt/etc/profile file you should have a line:
    export PATH=/opt/bin:/opt/sbin:$PATH





  • alfaalfa
    alfaalfa Posts: 6  Freshman Member
    First Anniversary
    Options
    Thanks kempiude for the prompt reply! 
    /opt/etc/profile contains this line. As for /opt/etc/init.d/S99ProfileHook, I have no such file. What should be a content of it? Could you paste yours? Many thanks!
  • Mijzelf
    Mijzelf Posts: 2,638  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Answer ✓
    Options
    You should install package profile-hook . It should be installed at setup, but maybe the server was not accessible?
  • alfaalfa
    alfaalfa Posts: 6  Freshman Member
    First Anniversary
    edited February 2019
    Options
    Thanks, Mijzelf!!! It turns out I was following an old tutorial and using your old repository. Placing a new repository in web_prefix file and reinstall solved this issue.
  • SELnas
    SELnas Posts: 2  Freshman Member
    edited October 2019
    Options
    I'm also newbie here. I've spent a lot of time searching forum & use Google too but no result. I hope it's most appropriate place for this problem (without start new discussion of course).
    After installation on NAS326 firmware V5.21(AAZF.4) package urbackup-server 2.3.8 from the newest Entware-ng and command:
    urbackupsrv -u admin run
    I can see only
    ERROR: Unable to change logfile ownership
    ERROR: Cannot get uid and gid of user "admin" -1. Errno: 2

    but "admin" user exists in the system
    cat /etc/passwd | grep "admin"
    shows
    admin:x:501:500:type&admin:/home/shares:/bin/sh

    I have got line
    ARGS="-u admin run --daemon"
    instead of
    ARGS="run --daemon"
    in
    /opt/etc/init.d/S60urbackup-server
    but result is the same: urbackup start failed.

    I have no clue what should be changed to make urbackup alive.
    Thank you in advance for any solution!



  • Mijzelf
    Mijzelf Posts: 2,638  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options
    When you install Entware-ng on a firmware 5 device (or actually on an Armv7 device), Entware-ng is at install automatically upgraded to Entware. One of the differences is that Entware uses /opt/etc/passwd and /opt/etc/shadow. (Alternative install vs. standard install)
    So I think you are done if you create symlinks to /etc/passwd, /etc/shadow and /etc/group in /opt/etc/
  • SELnas
    SELnas Posts: 2  Freshman Member
    Options
    Simple, elegant and effective solution (I should developed it on documentation basis but I haven't - the devil’s in the detail).
    Thank you for your quick help and all hard work for ZyXEL users community.

    Kudos GURU

Consumer Product Help Center