[NAS542] Slow speed with nfs

vidra Posts: 15  Freshman Member
edited August 2019 in Personal Cloud Storage

I am experiencing an issue: my transfer speeds are very slow (~50MB/s) and I cannot figure out why.
My exports look normal and the only thing I have changed is sync to async to see if i would make a difference(it does not). The problem is quite strange because the speed (when I test it) jumps to 1.5GB/s and then the transfer stops until it just jumps to finished. My average then is around ~50MB/s. This happens if I test with dd or just a file copy with thunar.
I find this very strange, and I must mention that when I was using my older NSA325 with the same disks I did not experience anything like this.

Does anybody know what is going on and how I can fix this.  i should also point out that i cannot mount nfsv4 - if that is related.

Thank you for your help!

Edit 1. : I have reinstalled NFS from app center and now nfsv4 works, the speed is still the same. And I have noticed that my cpu usage (on nas) goes to 97% with nfsd being 70%, i doubt that this is normal.

Edit 2. : I have tried to transfer data back to my pc and the speed is normal (110+ MB/s), cpu usage is also not high.



  • AntonioDB
    AntonioDB Posts: 3  Freshman Member
    Linux caches in RAM the data written to disks, also for network mounted disks (NFS), so you see 1.50 GB/s at the beginning because of caching.
    If you are using a HDD I think that 50 MB/s speed is due to HDD writing speed and not so speedy hardware ff the NAS.
    Read speed is always higher for any disk, also SSD.

  • vidra
    vidra Posts: 15  Freshman Member
    edited September 2019
    I was using the same disk with NSA325 and I was getting full gigabit. Is there a way to set up ssd caching with nas542?
    Edit: I installed an SSD in to the NAS and the speed is the same (~50MB/s). So it is not the disk that is not preforming well.

  • vidra
    vidra Posts: 15  Freshman Member
    edited September 2019
    Could mtu be the problem ( i can't set it higher than 1500 on nas) and I can not enable/find jumbo frames in web interface .
    Changed mtu to 9000 on all devices. Speed is the same. My load average is 3.76 which is a bit strange
Sign In to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click on this button!