I can't access (read, write etc) my files as top admin - NAS326

JojjeGee
JojjeGee Posts: 5  Freshman Member
edited September 2019 in Personal Cloud Storage
Hello!
Logged in as admin given all rights I cannot download or have read access to all of my files. How can I rescue my files or reset my admin password to garanteed success?
I have tried; resetting and adding other admin accounts, removed odd characters from names and passwords, tried logging in and downloading files through, desktop afp, -smb, browser and FTP.,
Some files works with no problem others generate "permission denied".

I access the NAS page through Firefox as Chrome has been troublesome to use with the login.
I run on mac OSX High Sierra 10.13.6.

Last Check 2019/09/22 19:38:45
Model Name
NAS326
Current firmware version
V5.21(AAZF.3)


Please help. I am getting desperate.

Kindly, Jörgen


#NAS_Sep_2019

All Replies

  • lodiabai
    lodiabai Posts: 120  Ally Member
    How do you access your files?
    Does the folders has admin right?
  • JojjeGee
    JojjeGee Posts: 5  Freshman Member
    Hello and thank you for your answer.
    I have tried several methods. Currenly I am trying FTP (trough port 21 in Transmit app) and AFP (in Mac system). It seems though I can't login on both at the same time.
    The admin account has total read & write access.
    What I can tell now is that some of the files might have been currupted (but not all files in the same folder). The files is there but I can't download anything without getting the access error message.
    This might not be an access problem after all even if that is the error message I get.
    Any thoughts on this? Can I rescue my files?
  • lodiabai
    lodiabai Posts: 120  Ally Member
    Does FTP work to download/backup your files?
    It's strange that you cannot access some files via admin account.
    How do you transfer the file to NAS326? Downloaded from Internet to NAS326 or uploaded files from your Mac devices to NAS326?
  • Mijzelf
    Mijzelf Posts: 1,717  Guru Member
    How about a hardware problem? Enable the ssh server, login over ssh and run dmesg. If that shows any I/O errors your disk might be dying.
  • JojjeGee
    JojjeGee Posts: 5  Freshman Member
    edited September 2019
    @Mijzelf Now I am entering, for me, unknown territory. Yes, I get a list of errors some saying stuff like "error count: 12683397", "md2: unknown partition table" and  "comm mt-daapd: bad entry in directory: rec_len is smaller than minimal" but no I/O errors (I made a search).
    This terminal might open up some possibilities I assume. Perhaps there is a way to fix broken videofiles or their seemingly broken read and write rights?

    @lodiabai I can read and write most files except those I need the most (of course). I get "permission denied" on those files. Proper file sizes and what I assume just broken file headers(?).

    As you both can tell I am not very knowladgeble in server service and am very thankful to you for your help guys!
     




  • Mijzelf
    Mijzelf Posts: 1,717  Guru Member
    Those errors don't sound alarming. That 'error count' doesn't sound familiar, but the 'unknown partition table' is only shown at boot, which means you don't have much errors anyway, else this error would have been flushed, as the buffer is only 64k.

    You can try to access your files using WinSCP. It uses the ssh server to access the files, and if you login as root, with your admin password, there are no permission problems which can stop you.
    The shares can be found in /i-data/<some-hex-code>/

  • JojjeGee
    JojjeGee Posts: 5  Freshman Member
    Good to hear nothing is broken. Perhaps the files was corrupted during transfer at some point.
    Running in OSX I can't use WinSCP but downloaded Cyberduck. I did manage to get the info through the systems Terminal the last time but can't figure out how to access the i-data folder.

    Cyberduck however get me a 500 error "This security scheme is not implemented. Contact your web hotel for help." when trying to move or rename the corrupt or any other files in the folder. Nor can I rename the folder itself.

  • Mijzelf
    Mijzelf Posts: 1,717  Guru Member
    Web hotel?

    Anyhow, error 500 is an http error. The intention is to use sftp. According to it's specs Cyberduck supports that, but maybe you have to specify that explicitly.