Multy X and powerline adapters

Zemfira Posts: 7  Freshman Member
edited November 2019 in Multy WiFi System
Hello everyone. I have 4 Multy X nodes working in our house, and the network  looks like this:
1) Xiaomi Mi Max works as 4G-router and gives internet to the iMac. By the way, please do add an USB-router function to that “placed-for-the-future-needs” USB-port in the Multy nodes firmware!
2) Then iMac “provides” an ethernet connection to the main Multy X node. iMac is set up to share usb-internet through ethernet connection.
3) Zyxel PLA5456-1 is connected via ethernet cable to the main Multy node.
4) The second PLA module is connected to the TV in the basement where no Wi-fi.
All of the devices worked fine together till yesterday, but not now. I can’t get TV connected to the internet to use it’s Smart-tv features.
The AIShield shows the TV, but TV obtains IP like 169.254.x.x.
I tried to restart and reboot everything, tried to change cables to new one. Is it possible to downgrade the Multy? I suspect that the new firmware ruined it all.
Wi-Fi connection works normally though.



  • Zemfira
    Zemfira Posts: 7  Freshman Member
    Update. Yesterday I’ve resetted everything again, log out and cleaned “My home” in the Multy App and setup everything again. They have worked fine for a couples of hours: devices had obtained right IP through powerlines and after couple of hours Apple TV again showed “No connection” and IP 169.254.x.x:((((
  • Zyxel_Eric
    Zyxel_Eric Posts: 279  Zyxel Employee
    First Answer First Comment
    edited November 2019
    Hi @Zemfira,

    We have received your feedback from Multy App, and we will assist you directly via mail.

    Best Regards,

Consumer Product Help Center