hostname.zyxel.me is not working, while UPnP is setup correctly. How to solve this?

Options
rvm
rvm Posts: 6  Freshman Member
edited December 2019 in Personal Cloud Storage
As can be seen in mycloud.zyxel.com the UPnP is setup correctly. But I cannot open the hostname.zyxel.me webpage (where hostname is the name I set in the setup). I read on this forum that I probably need to open a port on my router, but I was not able to figure out how.

Can someone help me out? I have a Zyxel NAS326 and a Draytek vigor 2132F router.



#NAS_Dec_2019

Accepted Solution

  • Mijzelf
    Mijzelf Posts: 2,639  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Answer ✓
    Options
    vanmanen.zyxel.me resolves to an ip address, which should be your public ip address. If your router responds to ping on it's WAN interface, you can ping it.
    You can't ping a port. Ping is an icmp protocol which doesn't support the concept of ports.

    As far as I can see your dyndns works, and so does your portforwarding. Your browser is complaining that your NAS can't prove it's the 'real' vanmanen.zyxel.me. For that the NAS needs a certificate which is signed by a third party.

    I think you can tell your browser to connect anyway, using the 'advanced' button.

All Replies

  • eozrocwd
    eozrocwd Posts: 58  Ally Member
    edited December 2019
    Options
    You need to set the port forwarding rule on your Draytek Vigor 2132F.
    Introduction: https://portforward.com/draytek/vigor-2132f/
    (Example: External Port:8443 <---> Internal Port:443)

    After done, you should able to access your NAS326 from outside via the link -> hostname.zyxel.me:External Port. Example: https://abcxzy.zyxel.me:8443
  • rvm
    rvm Posts: 6  Freshman Member
    Options
    Thanks for your reply. But I am still not able to access my NAS. The screenshot below shows the Open Ports configuration of my router. I set the 'Private IP' to the IP adress of the NAS.

    What do I need to do more?


  • eozrocwd
    eozrocwd Posts: 58  Ally Member
    edited December 2019
    Options
    My bad. Please delete the rule of open ports.

    Please try to use Port Redirection.
    https://www.draytek.com/support/knowledge-base/5749

    Public Port: 8443, or you can set another number.
    Private IP is your NAS326 LAN IP.
    Private Port: 443, it is for accessing NAS326 via https, please make sure it is enabled.


    After done, checked "https://hostname.zyxel.me:8443".


  • rvm
    rvm Posts: 6  Freshman Member
    Options
    I did the port redirection and enabled the HTTPS connection, but it is still not working.

    What I did found is that according to the control panel there is no UPnP Port Mapping enabled (see image below). Could that be an issue?


  • eozrocwd
    eozrocwd Posts: 58  Ally Member
    Options
    What kind of address you accessed? Is there any error message?
    Can share the screenshots?

    When you checked UPnP Router, what it the status? (Found UPnP supported router?)
    What is your network topology?

    When you ping "domain name", the response IP the same as WAN IP of your router?
  • rvm
    rvm Posts: 6  Freshman Member
    Options
    When I try to access: "https://vanmanen.zyxel.me:8443", I get this error:


    This is the UPnP router status:



    I have my NAS connected directly to the router with a ethernet cable. And I use the wifi connection of the router to have network connection with my laptop. No other devices are involved.

    I can ping to "vanmanen.zyxel.me", but not to vanmanen.zyxel.me:8443. Then I get: "Ping request could not find host.
  • Mijzelf
    Mijzelf Posts: 2,639  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Answer ✓
    Options
    vanmanen.zyxel.me resolves to an ip address, which should be your public ip address. If your router responds to ping on it's WAN interface, you can ping it.
    You can't ping a port. Ping is an icmp protocol which doesn't support the concept of ports.

    As far as I can see your dyndns works, and so does your portforwarding. Your browser is complaining that your NAS can't prove it's the 'real' vanmanen.zyxel.me. For that the NAS needs a certificate which is signed by a third party.

    I think you can tell your browser to connect anyway, using the 'advanced' button.

  • rvm
    rvm Posts: 6  Freshman Member
    Options
    Thanks, I can indeed access the NAS by connecting anyway.

    So I set it up, with HTTP in stead of HTTPS, so I do not get the safety error anymore. Or do I then risk other safety issues?
  • Mijzelf
    Mijzelf Posts: 2,639  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options
    Yes. When using https without qualified certificate, your browser tells you it can't verify the identity of the server, but meanwhile the connection is encrypted.
    When using http verification is not possible. For that reason the browser doesn't warn you. But that doesn't mean it's safe. And http doesn't support encryption.

    So if you are connecting over http, and someone can sniff your network traffic, they can read your password. When you use https without certificate, the password cannot be sniffed. Due to the lacking certificate it's possible to use a rogue 'man-in-the-middle' server to get the password, but that is a lot more complicated.
  • eozrocwd
    eozrocwd Posts: 58  Ally Member
    Options
    recommended to use https.

Consumer Product Help Center