Zyxel NAS542 - Wake on LAN not working

Options
npreis
npreis Posts: 5  Freshman Member
edited January 2020 in Personal Cloud Storage
Hi,
My NAS542 does not start on Wake on LAN anymore. It was working on the NAS320 I used previously.
The setting for WoL is set. Did something change in the firmware?
Thank you
npreis


#NAS_Jan_2020

Accepted Solution

  • npreis
    npreis Posts: 5  Freshman Member
    Answer ✓
    Options
    Now I think I found the twist in my NAS542.
    As soon as the network card are combined, the WoL won't work anymore. As long as you keep the 2 NIC separate it works.
    I never stop learning...

All Replies

  • Mijzelf
    Mijzelf Posts: 2,645  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options
    anymore

    Did it ever work that 542, or did you exchange the NSA320 by a NAS542 and did you expect the WOL to work out of the box?

    How do you perform a WOL request?

  • npreis
    npreis Posts: 5  Freshman Member
    Options
    It did never work on NAS542 so far. But I started to try to use it a few month ago. And the settings for WOL are set on the NAS.
    It was working on my old NAS320 perfectly.
    I connect to my router and try to wake up the device from there, as it was working with the old NAS.
  • Mijzelf
    Mijzelf Posts: 2,645  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options
    To use WOL the WOL software needs the MAC address of the target. Did you provide that?
  • npreis
    npreis Posts: 5  Freshman Member
    Options
    I connect myself directly to my router which provides the WOL functionality. There I select my device (also MAC address) and start it. With the old NAS320 it worked perfectly. And WOL still works with my PC.
    Something is wrong with the functionality in the NAS542 firmware, I guess.
  • Mijzelf
    Mijzelf Posts: 2,645  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options
    Well, it works for my 520, which is basically the same box. But the setting database is not rocksolid. So a factory reset might help.

    Is there anything between the router and the 542, except for dumb switches? WOL relies on UDP broadcasts, and not every network node passes that. On the other hand, if the NAS is known by name and MAC in the router, I guess the DHCP ICMP broadcast originating from the NAS reaches the router.


  • npreis
    npreis Posts: 5  Freshman Member
    Answer ✓
    Options
    Now I think I found the twist in my NAS542.
    As soon as the network card are combined, the WoL won't work anymore. As long as you keep the 2 NIC separate it works.
    I never stop learning...
  • dernachtwerker
    Options
    Hi, I did a litle tutorial in German language, here :
    http://software.ipw.net/die-wake-on-lan-funktion.html
     - you may use the google translator - I have 3 NAS (540 and 542) and all are going to sleep and getting awake from Windows XP and Windows 10

Consumer Product Help Center