HTTPS and Certificate

Markus Posts: 2  Freshman Member
edited February 2020 in Personal Cloud Storage
Hi there,
  I think I need your help:
  I configure a little with the connection "HTTPS only" and the certification and now I do not get access to the web interface.
  Is there a way to disable HTTPS and use normal HTTP using SSH command?


  Thanks for your help!



  • Batou
    Batou Posts: 101  Ally Member
  • Markus
    Markus Posts: 2  Freshman Member
    edited February 2020
    Thank you! 
    But is there any other way? The reset is my final option. I configured the Nas with many share folders and dns etc. 
    I even create an new certificate with ssh but the browser ignore it. 
  • Mijzelf
    Mijzelf Posts: 2,645  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Maybe. If you are a bit into Apache. The webinterface runs on Apache, and I *think* HTTPS only is forced by some redirect rule.
    If you remove that redirect rule and restart the webinterface, it might work.

    The config file for the main webinterface is /etc/service_conf/httpd.conf. You can reload the webinterface by

    /etc/init.d/ reload

    Don't worry to screw things up. The apache configuration is completely in ram, and is rebuild on boot.

Consumer Product Help Center