Is it possible to mount another NAS to my existing one?

AleXSR700
AleXSR700 Posts: 41  Freshman Member
edited February 2020 in Personal Cloud Storage
Hi,
I would like to add a mount to my second NSA325v2.

I tried 

[email protected]:/ffp# mount -t cifs //192.168.0.10/BackMisc_nfs/BackMisc_nfs/path path
mount: wrong fs type, bad option, bad superblock on //192.168.0.102/BackDownMisc_nfs/BackDownMisc_nfs/pahe,
       missing codepage or helper program, or other error
       (for several filesystems (e.g. nfs, cifs) you might
       need a /sbin/mount.<type> helper program)
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

[email protected]:/ffp#

Is there a way to do this? I know it is possible to backup data to another NAS via the webUI. But it must also be possible to create a direct link so I can copy files via the command line to the second NAS.

Anybody have any ideas?
The second NAS is currently an NFS share but can also be accessed by Windows, so also works as a Samba share.


#NAS_Feb_2020

All Replies

  • hunandoz
    hunandoz Posts: 17  Freshman Member
    Hi, I do not know what exactly you would like to copy, but you can ssh / ftp to the other NAS for sure from mc, and then you can do the copy. If you would like to automate some backup in cron this is not a solution, or you should write some script for access start copy - this is much far from my basic knowledge.
  • Mijzelf
    Mijzelf Posts: 1,975  Guru Member
    I have never tried this, but I think an NFS mount should be possible:

    mount //192.168.0.10:/path/to/nfs/share mountpoint

    You should be able to see the full pathnames with

    showmount --all 192.168.0.10

    For cifs you need the cifs kernel module. I can't remember if it's available in the kernel module package for ffp which I provided years ago. And maybe you'll need a special mount binary, as your error suggests.

    A third option is sshfs, which runs on top of fuse. You'll need the binary, which might be available in ffp or entware-ng.

    sshfs 192.168.0.10:/i-data/sysvol/share path

    Unmount with

    fusermount -u path

    A problem with this is that it uses encryption, which limits the speed to about 1MB/sec.