NAS 326 Read-Only File System

Gio24 Posts: 3  Freshman Member
Hi everyone,
   i've updated the Nas326 to the latest FW available, the V5.21(AAZF.8), later i tried to remove some files from the admin directory using the FileManager built-in application but it seemed that nothing happens, infact the file was not removed.
I searched on this this forum and a possible solution i found was that downgrading the FW to a previous release could resolve the issue, i tried with V5.21(AAZF.5)/V5.21(AAZF.1)/V5.21(AAZF.0) without any changes, the problem still remain.
So i tried to connect to the NAS using FileZilla via ftp using admin account, but when i tried to delete those files the server responded with Response: 550 Can't remove directory: Read-only file system.
So what can i do to resolve this issue? I already control the account permission and the admin account has all the read/write permissions needed.
The Nas is configured in RAID1.
Hope that someone could help cause i cannot empty the hdds.



  • Sakura_T
    Sakura_T Posts: 101  Ally Member
    First Anniversary Friend Collector First Answer First Comment
    edited April 2020
    Can you check SMART info of the HDD, maybe it's in bad health condition so not allowing to write anymore.
  • Gio24
    Gio24 Posts: 3  Freshman Member
    I checked both HDDs and they result to be in good conditions from the SMART info, infact i can write new data in it. 
    The problem seems to be on the FileBrowser utility, because using the Transmission application i'm able to add new files and to delete them from the application, but for everything else that is not listed there is impossible to delete any file.
    Is there a way to access to the HDD with root rights? Because using the admin rights seems to be not enough.
  • Gio24
    Gio24 Posts: 3  Freshman Member
    I finally made it. Using ssh root access over sftp i can delete files from every directory, it's been quite hard to find this solution and i think that it's not quite common to manage these kind of operations.
    I found similar posts on this forum but no solutions over fw updates, it's a fault of my NAS or a FW problem?

Consumer Product Help Center