Can you donwload directly to external drive using Download service?

Options
frigider
frigider Posts: 18  Freshman Member
i tried changing the path of the saved downloads but i cannot navigate elsewhere than "admin" default system share.
please see attached picture.

the external drive is OK, i have it mapped too.

i would not want to install Transmission app because i have this principle of installing as FEW apps as possible. 
but if Transmission would make it work... maybe i will install it.

i am pretty sure someone had this issue before i did. 
(i searched using "nas 326 download" and ...lots of pages.

All Replies

  • Mijzelf
    Mijzelf Posts: 2,642  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options
    If you are not afraid of the command line, you can create a symlink in the admin directory.
  • frigider
    frigider Posts: 18  Freshman Member
    Options
    Ok, i will google that, thank you!

    What happens if the external drive is removed and that link I create is no longer valid? 

  • frigider
    frigider Posts: 18  Freshman Member
    Options


    ** i installed Transmission and i can edit the location of the download - default is this one:
    /etc/zyxel/storage/sysvol/admin/download/Transmission/download

    which one is the path to the external HDD which is currently named "Mass-Storage-Device-4"?
    if i can type it correctly then it would probably work, right?

    i tried inserting it at different places (after sysvol, befor sysvol etc. to no avail)
  • frigider
    frigider Posts: 18  Freshman Member
    Options


    ***i am so sory for this!!!
    in the settings of the Download center you can select from the drop-down list the drive you want to download stuff onto!!!

    PROBLEM SOLVED :hushed:

  • frigider
    frigider Posts: 18  Freshman Member
    edited April 2020
    Options
    ****actually the download does not even start, at best you get the downloaded folder created on the external drive but it does not go any farther than this.

    still working on it. but hopes are at a all time low.

    for what it's worth - i am using older 320gb hdd, connected to the front port usb.

    will try to go "in the back" (ports)
  • frigider
    frigider Posts: 18  Freshman Member
    Options
    *5 looks like it worked somehow but cannot figure out how!
    (.torrent file needs to be in the external drive as well?? of you need to open it from there? or from admin share??? can't figure it out yet)
  • frigider
    frigider Posts: 18  Freshman Member
    Options

    I found out by trial and error that the steps are as follows:

    set download location to ext drive (i did it for incomplete and complete torrents)
    copy the .torrent file in the admin/downloads/torrents
    load the .torrent file from the above mentioned location

    and now it should work.
  • frigider
    frigider Posts: 18  Freshman Member
    Options


    it works only from time to time, very unreliable...

    VERY UNRELIABLE.. a true dissapointment
  • frigider
    frigider Posts: 18  Freshman Member
    Options

    If anyone finds a reliable way of doing this please post here..
  • maliburek
    maliburek Posts: 1
    First Comment
    Options

    Connect in nas whit ssh (telnet), put command "mount" and look for "/e-data/….."
    This is the path to the usb drive that you can use in the transmission program

Consumer Product Help Center