Is it possible to update OpenSSL on NSA325v2 to current version?

Options
AleXSR700
AleXSR700 Posts: 41  Freshman Member
Hi everyone,
I was just running a make of the newest softether vpn server and it shows an error because the OpenSSL installed is too old.
Currently the NSA325v2 runs on OpenSSL 0.9.8o 01 Jun 2010.

Is there an easy way to update it?

Comments

  • Mijzelf
    Mijzelf Posts: 2,645  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options
    I think you'll have to compile your own openssl. As the firmware depends on an older version, it's not possible to update the firmware openssl. So your softether will also need to search for openssl on a non-standard place. It might be possible to overcome that by linking a static version of openssl, so that softether doesn't need an external file, or by using another ssl library, like mbed TLS. Don't know if softether supports that.

Consumer Product Help Center