Make the Multy X behave like a bridge?

monotux
monotux Posts: 2  Freshman Member
edited June 2020 in Multy WiFi System
Hi,

I'm trying to make my Multy X act as an actual bridge in my home network. I've set it to act like a bridge through the app, but my wifi connected devices are still using the 192.168.212.0/24 address range which makes me confused. To all I can see, the Multy X device is still doing NAT, DHCP and DNS for it's connected clients.

I've connected a CAT6 cable from my switch to the WAN port of the Multy X and set it to bridge mode.

This is a diagram that describes my home network. The Multy X devices are just to provide WiFi, I want to manage DNS, DHCP and so forth myself using my existing setup.


I've also lost all access to my Multy X system since changing to bridge mode, even though the WiFi is still working fine. I've already had to reset my multy x nodes once of the same reason, and having to reset everything every time I want to make a configuration change is just unacceptable.

I realize that the Multy X product probably isn't for me, but I'd just like to see what can be done before I return the product. 



#Multy_May_2020

All Replies

  • Emerald Dragon
    Emerald Dragon Posts: 118  Ally Member
    First Anniversary
    edited May 2020
    I don't have Multy X, but the router configuration concepts still the same. If that's what your configuration for your network currently is. I can see why it's not working. Switch the two routers locations. The router using WiFi backbone should be connecting to the WAN not the one with bride mode. Once you fixed that, your problems should be solved.
  • Zyxel_Eric
    Zyxel_Eric Posts: 279  Zyxel Employee
    First Answer First Comment
    @monotux,

    Please make sure your Multy properly switches to Bridge Mode.
    In Bridge Mode, The DHCP server would disable on Multy, and all the traffic will pass through Multy from your Modem.


  • monotux
    monotux Posts: 2  Freshman Member
    Hi,

    sorry for this late reply. I could eventually make it work in a bridged configuration after resetting everything yet another time, and then it worked like expected.

    However, after having my equipment shutdown for 3 days (due to not being home) I had to reset everything yet another time to have it partially working again.

    After turning on the units again I could see that my 'primary' node (which is connected with a networking cable to my switch) was repeatedly trying to get a IP from my DHCP server, but didn't accept what was offered.

    My router leases addresses in the 172.19.37.0/24 range, and the Multy X node repeatedly tried to get an address in the 192.168.212.0/24 range, and just kept on trying to get an address in that range even though my DHCP server replied with one in it's range. After some time trying to get another address the router eventually started blinking red, and I tried to just reboot it a few times to see if it would help, but same result every time.

    Then I tried to reset the unit to redo everything yet another time. I could partially finish the process using my smartphone, but as soon as the Multy X tried to check for connectivity the process failed, and watching my DHCP server logs it exhibited the same issue! It tried to get an address in the 192.168.212.0/24 range. To be able to finish the setup process I had to connect the router directly to the internet, after which I could finish the process.

    I'm using DNSMASQ as my DHCP server, but I have a hard time believing that would be the root cause here (dnsmasq is used in basically every home router out there, most likely including the Multy X).

    What is going on here? I refuse to believe that I have to reset and redeploy my wifi network after any power outrage or shutting of the units. I bought the equipment after researching that it would support my use case (using it in bridge mode, more or less), be performant and not having issues like this. The current situation is just unacceptable!

Consumer Product Help Center