Web Publisher to use port 80

Options
Morton
Morton Posts: 3  Freshman Member
Hi.

I have problems with my NAS542 to use the Web Publishing.

I try to find the form to change the default  http://xxxxxx:5000/MyWeb/Sharedfolder   to external access throug using a http://xxxxx/

I configure my NAT router ports to redirect from port 80 to port 5000. And this part work fine, but I need to redirect directly to /MyWeb/www/  without I need to write this path in main URL.

In resume:
I HAVE:    http://xxxxxx/MyWeb/www/
I WANT:   http://xxxxxx/

\Morton

All Replies

  • Mijzelf
    Mijzelf Posts: 2,642  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options
    I think you have to setup a reverse proxy. On the NAS you can use Entware to install nginx which can reverse proxy.
    You can also use the stock apache, which also has the needed modules. If you use the stock apache, you'll have to use a copy of the binary (/usr/sbin/httpd), as the firmware regularly kills the webserver to restart it.

    Maybe proxying is not possible, it depends on the website. For instance if the website /MyWeb/www/ needs a resource located in /MyWeb/, it's not possible to proxy it to /.

  • Morton
    Morton Posts: 3  Freshman Member
    Options
    Hi Mijzelf.

    Thanks for you post. I will dig into your suggestions. I am new to unix / NasServers (I have for many years hosted my own Windows Exchange server) so I need to get acquainted with telnet prompt maintaining the server. Seems a little old fashion style.
    I truly had hoped for an easier approach to get the web publisher to use port 80.

    I will be glad to hear from others who might has an other approac to solve this issue, easier;-)

    Thanks so far for the comments. If I succeed in getting a solution I will post later:-)

    \Morton

Consumer Product Help Center