VMG8825-T50K and old Gigabit Switches

Jacksoft Posts: 2  Freshman Member
Hi, I have two unmanaged gigabit switches from another brand bought in around 2014 connected to two different ports on VMG8825-T50K Tiscali branded with FW V5.50(ABRN.0)b5_20190923.
The problem is that suddenly they stop working: devices recognizes the network but internet or any connection to them will not work and I need to reboot both devices and switches.
I found that Zyxel modem send so many ARP requests and I thougt that the problem could be it, because with the older modem (by another brand) worked flawlessy.
I do not want to buy a newer switch just to try without the aknowledge to fix the problem, I would ask if there's something I can do before.


  • Hummel
    Hummel Posts: 212  Master Member
    First Anniversary Friend Collector First Comment
    Do you mean you connect the 2 switches to VMG8825-T50K and then connect other devices to the 2 switches but suddenly the devices can't access the Internet?
    Can your devices get IPs from VMG8825-T50K correctly?
    I think when the problem happens, the best way is to simplify your network first.
    Try to connect your device directly to the LAN port of VMG8825-T50K. If it can work correctly, then the problem is at the switch side. If it still doesn't work, then there must be something wrong on VMG8825-T50K.
  • Jacksoft
    Jacksoft Posts: 2  Freshman Member
    Yes, you're correct.
    In a test I've connected one those affected devices directly on VMG8825-T50K, and it continue working without any problem while the switch on another port stops as always.
    I thougt about incompatibility/problem with the switches, because they're old (TL-SG1005D), also if it's strange (an incompatible protocol maybe?). But if I would buy a new one what I should check to avoid this problem again?
    Anyone could suggest me a good unmanaged gigabit switch?

Consumer Product Help Center