How to manually mount disks from terminal?

danyx Posts: 4  Freshman Member
I use 4 zyxel 542 NAS systems to backup a lot of photos.

Because I want to have one set of offline backup disks at all times and rotate these periodically, I have set up my system in such a way that for ever master, e.g. masterA I have two backup drives backupA1 and backupA2. One of those is always in storage, the other is in the same NAS as the master. Every now and then I want to rotate the offline and the online backup drive.

Every drive is configured as a single drive in the Zyxel Web UI, then I enabled ssh, installed entware-ng and set up rsync to periodically mirror from master A -> backupA1; master B -> backupB1 etc.

Then came the time for the first rotation and I took out the first set of backup drives (set 2 of the backup drives) and put in new backup drives. Again, initialized them as single disks and started copying.

Now I just tried to rotate back to the first set of disks but had to realize that the zyxel nas systems don't remember old single disks. I.e. through the web UI I can only format the backupA1 disk etc, but just inserting them does not get me back to the state I had before and no way to access the data or update the backup.

I then realized that even single disks are not handled as simple ext4 drives but go through the linux software raid mechanism. This means that I can't simply mount the ext4 filesystem and access my data that way.
It also seems that the NAS does not know anymore about the software raid setup for each of the backup1 drives.

My question is now: How can I mount the backup 1 drives into my nas system? I'm totally fine doing things on the command line but I don't know mdadm yet and was hoping that someone else might know.

Basically what I think I need to do is (re-?)create a software raid setup for each of the backup1 drives that just re-uses the already initialized backup1 disks and mounts them without formatting them. does anyone know how to do that?

Many thanks in advance!

All Replies

  • danyx
    danyx Posts: 4  Freshman Member
    Ok mystery solved :)

    It turns out linux software raids keep the information about the raid on the disks themselves. You can either restart and it will do a rescan on startup or rum
    mdadm --assemble --scan
    Then mount the /dev/mdX device somewhere and access it

Consumer Product Help Center