NAS540 RAID5, replacing drive, no repair option

Options
MV10
MV10 Posts: 13  Freshman Member
edited July 2020 in Personal Cloud Storage
I have three NAS540s, all with four 2TB drives. Each NAS is configured as one big RAID5 volume. I've done single-drive replacements before and I've always been prompted to repair the volume. As I understand it, with RAID5 I should be able to upgrade all the drives one by one, repairing the volume again each time I swap out a drive, right?

But when I tried swapping a drive just now, I got the "volume degraded" warning but no repair option.

Could this be because the new drive came out of another NAS540? In fact, it even came out of the same slot (#3) in the other NAS, could that be confusing the firmware, like maybe the drive is "marked" as slot 3? (One of my units had two drives less than 6 months old, so I was going to move them to the other NAS as part of this upgrade process, they happen to match the brand/model.)

The Manage button on the Volume screen was grayed out and in addition to the Volume entry, it also listed drive 3 separately as "hot spare". Since the original very-old drive 3 hadn't failed, I reinstalled it and now that did prompt to repair and is re-syncing while I try to figure out what to do.

I have very basic Linux experience (long-time Windows dev) and I've enabled SSH and have puTTY installed and verified I can login. I've read some similar troubleshooting threads but don't know what I'm looking at, so I'm not sure what to do next.


#NAS_July_2020

Comments

  • Dexter
    Dexter Posts: 108  Ally Member
    First Anniversary Friend Collector First Comment
    edited July 2020
    Options
    Do you mean you put this drive back to the original NAS540 and it will appear "repair"? Have you tried a brand new drive to the NAS that you want to upgrade? 
  • MV10
    MV10 Posts: 13  Freshman Member
    Options
    Thanks, no -- if we call them NAS "A" and "B":

    "A" is getting all brand new drives. It had two old drives (to be discarded), and two almost-new drives (to be reused in "B").

    "B" has an almost-new drive (to keep), but three old ones I want to upgrade, one by one, repairing after swapping out each one. The two almost-new drives from "A" will be moved into NAS "B" as part of this one-by-one upgrade/repair.

    But when I pulled "A" drive #3 and put it into "B" slot #3, it said "degraded" without a repair option.

    At that point I stopped, re-installed the original "B" #3 and that is repairing now. I don't know why A #3 installed into B #3 didn't give me a repair option.
  • Mijzelf
    Mijzelf Posts: 2,638  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options
    I *think* the NAS is confused by the raid header on the replaced disk, which makes it doesn't want to add it to an existing array.
    If you have the possibility to erase the first megabyte, or remove all partitions or something like that, that might solve the problem.

  • MV10
    MV10 Posts: 13  Freshman Member
    Options
    I removed the partitions and now I get the repair option. Thank you both!

Consumer Product Help Center