Print server on NAS542

eried Posts: 7  Freshman Member
Hi, I havent been able to use my printer (which worked with cups in Raspberry Pi). My printer appears "Offline" and if I try to delete it or rename it I get Error 500

How can I reset cups in the Nas542? I tried via SSH but I just get permission denied trying to delete the .conf files related with the printers


All Replies

  • Dexter
    Dexter Posts: 108  Ally Member
    First Anniversary Friend Collector First Comment
    Have you tried to reboot NAS? Did you use root or admin to SSH NAS?
  • eried
    eried Posts: 7  Freshman Member
    Yes rebooted several times, and also upgraded the firmware to latest yesterday. BUT! I was admin. 

    As root I was able to delete those files! yay! thanks a lot.

    I will check if I can make the printer work now.  :'( vi is horrible, I wish uboot had nano at least.
  • eried
    eried Posts: 7  Freshman Member
    OK, so how I fixed this: 

    1) Unplug the printer
    2) Delete etc/cups/printers* in SSH
    3) Delete the current printer in /etc/zyxel/py_conf (leaving [[[printers]]] header empty)
    4) Reboot the NAS
    5) Plug the printer

    Do not change the name or do anything with the printer. It does not work and everything get stuck. After this you can add the printer in Windows with:
    http://nas_hostname:631/printers/Name_displayed_on_config_copy_with_edit(but dont edit it)

Consumer Product Help Center