Problem trying to run PiHole with Zyxel Multy X Wifi.


Home Setup as follows:

Virgin Media Superhub in Modem Mode, plugged into the WAN port of the primary Zyxel Multy X in the lounge. 3 further Multy X devices around the house in the same network acting as WiFi points

One of these is in the study, Rpi with PiHole installed on it plugged into an Ethernet port

I configure PiHole, DHCP Server *off*, and have a static IP set (which I reserve in the Multy X config).

Go into the Multy X settings, set the IP of the PiHole as my primary DNS server.

Within 10 seconds the Multy X re-ip's my entire network (EG taking from 192.x.x.x to a 10.x.x.x network).

This happens with brand new installs of PiHole (as in format SD card, reinstall Raspbian, etc) . Tried rebooting the router, tried plugging the Pi into different MultyX's, etc.

Is this an issue where the Multy X won't allow a local DNS resolver?????


  • Mijzelf
    Mijzelf Posts: 2,607  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Are you saying:

    You have a network 192.168.x.0/24
    You connect a PiHole in the same range.
    -- Everything keeps working.
    You configure the router to use the PiHole as DNS
    -- Boom! The router reconfigures itself to use a 10.x.y.0/24 network?

    In that case, does the router has any interesting logs?
    And the PiHole, AFAIK it can show which requests were 'blocked'. Did it block any request coming from the router itself?
  • Zyxel_Eric
    Zyxel_Eric Posts: 279  Zyxel Employee
    First Answer First Comment
    edited July 2020
    Dear Sir,

    Please refer to the KB link of Why does my Multy LAN IP switch to!viewDetail.action?articleOid=018001&lang=EN

    The DNS setting on Multy App is for the public DNS server, do not set a DNS server in the Multy Local Network.
    If user set the customize DNS with 192.168.212.X on Multy App, Multy will detect the WAN IP conflict with the local IP and reconfigure the local network setting, then switch the IP from to 

    Best Regards,

  • Brezz
    Brezz Posts: 1
    Dear Eric

    I have the same problems as those here.  hoping for a firmware update soon


Consumer Product Help Center