NAS540 Cant upgrade firmware

Proffsjonny
Proffsjonny Posts: 2  Freshman Member
Hi! I have a NAS540 with firmware V5.04(AATB.0). I have tried everything to upgrade the firmware but it dont work, always get the message "Invalid firmware file". Is the NAS damaged or is there anything i can do? Best regards Jonny.

Accepted Solution

  • Mijzelf
    Mijzelf Posts: 1,579  Guru Member
    Accepted Answer
    Do you have a volume >16TiB? In that case you can't upgrade. Else try the oldest you can find. ZyXEL offers 5.11 for download, 5.10 would be better. Starting with 5.10 a new kernel was introduced, which had big impact on the upgrade process. So I can imagine you can't make a single jump from 5.04 to 5.20.

All Replies

  • Proffsjonny
    Proffsjonny Posts: 2  Freshman Member
    Yes i have a v.olume >16TB. Tried with firmware 5.11, didnt work. Then i tried with 5.10, that worked fine! Unfortunately all data disappeared from the discs, fortunately i have a complete back-up. Now im up and running firmware 5.21. Many many thanks!
Sign In to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click on this button!