Multy X set up issues

feastofblaze Posts: 1
edited August 2020 in Multy WiFi System

I've been spending an afternoon or so trying to set up a Multy X mesh network and I'm about ready to give up.

I seem to be able to connect one Multy X to my home router fine, but as soon as I connect another Multy to the primary one things start to go wrong. The network disappears every 5 minutes or so, and the white LED flashes on the primary Multy while the secondary one eventually goes solid red. I have followed the instructions on the app, the devices are both up to date and have been rebooted multiple times, the Multy's are the right distance apart... I've tried starting from scratch. I have emailed support but I thought I'd ask here too.

Any help would be massively appreciated!


All Replies

  • PeterK
    PeterK Posts: 38  Freshman Member
    edited August 2020
    Do you mean that you did install the second Multy successfully, but the second multy would disconnect every 5min? 
    You can try to connect them with Ethernet as a test. see if the issue would still happen again.

    You can also send feedback from the App for help.

  • Beeeezo
    Beeeezo Posts: 2  Freshman Member
    Hi Guys,
    Has anyone found certain symbols or "special Characters" on certain mobile phones will not work on password setup, found this out today, tried inputting ISP password on my Hauwei, just would not allow me to input = sign...?? then I tried the same setup but on an iPhone and it accepted the = symbol and setup, added the Mini and works great,.... strange ?? 
  • Keroro
    Keroro Posts: 12  Freshman Member
    edited December 2020
    I do not have Huawei mobile.
    So far, we do not met the symptoms on my iPhone, everything just works fine.

Consumer Product Help Center