Entware/Python2 broken

Options
ariek
ariek Posts: 30  Freshman Member
First Anniversary 10 Comments
edited October 2020 in Personal Cloud Storage
Device: NAS520/latest firmware.

My python2 installation under Entware is broken and I need it because some apps refuse to work under python3 (3.8.5). I can't repair it because the files are no longer in the repository. I'm aware that python2 is EOL and last release was Python 2.7.18.

Updated all packages:
opkg update
Downloading http://bin.entware.net/armv7sf-k2.6/Packages.gz<br>Updated list of available packages in /opt/var/opkg-lists/entware
Downloading http://zyxel.diskstation.eu/Users/Mijzelf/Entware-ng/binaries/armv7/Packages.gz
Updated list of available packages in /opt/var/opkg-lists/Mijzelf
The updated list includes python 2.7.14-5, but thes packages are not available at:
http://bin.entware.net/armv7sf-k2.6/
Is there a way to fix this or reinstall Python 2.7.9 or (2.7.14-5) any other way?

python2 -V Python 2.7.9
De code editor is messy.







All Replies

  • Mijzelf
    Mijzelf Posts: 2,639  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options
    Are you sure python2 came from the Entware repository? You can find python 2.7.14-5 in the Entware-ng repository, which was the predecessor of Entware, in this case.
  • ariek
    ariek Posts: 30  Freshman Member
    First Anniversary 10 Comments
    edited October 2020
    Options
    No.

    <div>which python2</div><div>/usr/bin/python2</div><div>which python3</div><div>/opt/bin/python3</div>
    Is there a way to use/point to the Entware-ng repository from the command line? For single use only and doesn't need to change the
    http://bin.entware.net/armv7sf-k2.6/
    in pkgcgi.cgi and opkg.conf







  • Mijzelf
    Mijzelf Posts: 2,639  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options
    According to the opkg manual, you can execute 
    <div>opkg install http://pkg.entware.net/binaries/armv7/python_2.7.14-5_armv7soft.ipk</div><div></div>
    but I don't know if it will draw the dependencies from the same page.


  • ariek
    ariek Posts: 30  Freshman Member
    First Anniversary 10 Comments
    Options
    I fixed it using the system python2 (/usr/bin/python2; Python 2.7.9).
    The entware Python 2 require building a new package list. It can be done but takes more time than using the build-in python2 variant.


Consumer Product Help Center