External hard disk couldn't be formatted on the Zyxel NAS 326 anymore

Hi folks.
Following situation:
I have two Zyxel NAS 326 -> firmware V5.21(AAZF.9)C0

Months ago I connected a 5TB USB-drive from Western Digital on each of them. I formatted the external disks with ext2 and everything was alright.

Meanwhile there was the firmware update to V5.21(AAZF.9)C0 (no idea if this really matters) and after a freeze and hard-reset of one NAS I had to reformat the external disk, because it was shown with the original device name and seemed to be formatted with NTFS. But formatting the disk again doesn't work (neither on NAS one or two) and even editing the name of the disk failed with the message "unexpected error".

I thought this HD could be defective although it worked fine on my iMac where I could format and use it in any way but connected it back to the NAS it shows always the original device name and NTFS as format (and almost empty despite of loading lot of data to it).

So I bought another 5TB Western Digital HD an tried it again, but the problem is still the same:
I couldn't format it at all and also editing the name of the disk fails.

Now I have 3 HD, one works fine on NAS 1, the other 2 disks couldn't be formatted or edited on NAS 1 and 2.

Any idea or hint?

Thx in advance.

Cheers
Kaspar

All Replies

  • Mijzelf
    Mijzelf Posts: 1,559  Guru Member
    Can you connect 1 working an one not working disk to NAS 1, login over ssh as root, and post the output of

    cat /proc/partitions
    parted -l
    cat /proc/mounts

Sign In to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click on this button!