NAS326 : failed to expand volume1

Options
Hi,
  I replaced my smaller(0.9TB) disks with the larger ones(one by one as per instruction) The data has been copied successfully. Then I tried to expand my drive to existing maximum(1.8TB) according to the manual for the NAS326. But it shows status(Storage manager -> looking into status) as in process "Volume 1 is expanding" for days. I tried to restart it and kick off the process again(Storage manager -> Internal storage -> Volume -> Manage button -> [expand option] ) but the result was the same: it shows "Volume 1 is expanding" for ages.
  Finally I found out in log file in device "Expand volume [Volume 1] FAILED" After that it became clear something went wrong with expansion.
  If I look into current status of mdadm(cat /proc/mdstat) I see such a picture:

~ $ cat /proc/mdstat 

Personalities : [linear] [raid0] [raid1] [raid6] [raid5] [raid4] 

md2 : active raid1 sdb3[3] sda3[2]

      1949383680 blocks super 1.2 [2/2] [UU]

      

md1 : active raid1 sdb2[3] sda2[2]

      1998784 blocks super 1.2 [2/2] [UU]

      

md0 : active raid1 sdb1[3] sda1[2]

      1997760 blocks super 1.2 [2/2] [UU]

      

unused devices: <none>


Actually, I don't understand why there are 3 disks, not 2. But all of them seem to be OK.

and df -h shows such a picture:

~ $ df -h

Filesystem                Size      Used Available Use% Mounted on

ubi4:ubi_rootfs1         88.1M     48.2M     35.5M  58% /firmware/mnt/nand

/dev/md0                  1.8G    145.9M      1.6G   8% /firmware/mnt/sysdisk

/dev/loop0              138.5M    121.8M     16.7M  88% /ram_bin

/dev/loop0              138.5M    121.8M     16.7M  88% /usr

/dev/loop0              138.5M    121.8M     16.7M  88% /lib/security

/dev/loop0              138.5M    121.8M     16.7M  88% /lib/modules

/dev/loop0              138.5M    121.8M     16.7M  88% /lib/locale

/dev/ram0                 5.0M      4.0K      5.0M   0% /tmp/tmpfs

/dev/ram0                 5.0M      4.0K      5.0M   0% /usr/local/etc

ubi2:ubi_config           2.2M     80.0K      2.0M   4% /etc/zyxel

/dev/md2                912.9G    865.5G     47.3G  95% /i-data/1a2b3c4d

/dev/md2                912.9G    865.5G     47.3G  95% /usr/local/apache/htdocs/desktop,/pkg

Since it's not a pure ubuntu installed in NAS I cannot use sudo and try to expand by myself from bash(moreover it may lead to losing the data) And I cannot see system logs for digging into failure more deeply.

Version of NAS software is the latest(I checked for updates): 

Model Name
NAS326
Current firmware version
V5.21(AAZF.9)C0

Saying all that above could someone provide a workaround to avoid the problem with raid size expansion after putting large size disks into NAS?

Accepted Solution

All Replies

Consumer Product Help Center