NAS542, unable to expand RAID1 volume

jpop Posts: 6  Freshman Member
edited January 2020 in Personal Cloud Storage
I have a NAS542, latest firmware, V5.21(ABAG.3).

On it there is a RAID1 configured as single volume built directly on RAID, consisting of 2x2TB disks. I want to expand it to 2x4TB and get a 4TB RAID1 configuration. Doable, right?

The procedure is supposed to be to replace disk by disk, and then expand the volume. So I took out one 2TB disk, replaced it with a new 4TB disk. Rebuilt. Everyhing fine. After re-syncing, replaced the other 2TB disk with a 4TB. Rebuilt, resynced. Now I have 2x4TB disks. But I cannot expand the volume to include the empty space:

Manage option is grayed out. Obviously, there is space to expand, status of the volume is green, data is there and accessible. No problem that I can see. Still, it won't let me. Why? How would I go about expanding the volume to use up the empty space?


Accepted Solution

  • Mijzelf
    Mijzelf Posts: 2,339
    100 Answers 1000 Comments Friend Collector Fifth Anniversary
     Guru Member
    Answer ✓
    As far as I know that screenshot means you have a 3.58TB volume, which is about 50% used.

All Replies

  • jpop
    jpop Posts: 6  Freshman Member
    OMG, what a doofus I am. :-) I didn't even check, because I expected to have to manually expand the volume into the newly available empty space. Instead, it looks like the rebuild and resync process itself expanded the volume automatically. You are indeed correct, 3.58TB is the size of the volume.

    What tripped me up is that I also have a another volume on disk group, which I had to expand manually when I replaced the disks with bigger ones. Ah well. Imaginary crisis solved. ;-)
  • gtdaniel
    gtdaniel Posts: 8
    First Comment Third Anniversary
     Freshman Member
    edited April 2020
    I run into a similar situation... I have a NAS326 with 2 hdd of 4 TB in RAID 1 almost full (94%) and i buy another NAS542 and 2 hdd of 4 TB.
    I put NAS542 online with 2 hdd of 4TB in RAID 1 and copy all content from NAS326 via network.
    Until now all is fine, NAS542 is online with 2 hdd on RAID1 almost full (94%)...
    After that i pull out that 2 old HDD of 4TB from NAS326 and i want it to extend RAID1 volume from NAS542 with them. I put it online, all 4 hdd are fine, i chosse to extend volume with 2 new hdd, works fine to resyncing about 30 hours and after that i do not have any modification on capacity, it remain old 3,58TB...

    I must mention that i select only to expand RAID1 volume with 2 new hdd and i do not select any modification of RAID system...
    Now NAS are fine but i cand not use aditional capacity...

    What i do wrong?

    L.E.: I do not know if is relevant but i attach output of <cat /proc/mdstat> and <cat /proc/partitions> command...

    At <mdadm --examine /dev/sd(abcd)3> command i have approximation same result for sda3/sdb3/sdc3/sdd3...

    Somehow i have available 8TB but array size remain of 4TB...

    Thanks in advance!
  • Kim
    Kim Posts: 37  Freshman Member
    RAID 1 will only store data to one disk even if you have four discs.
    Other discs will be the backup
    If you want to expand volume, maybe you can change RAID type from 1 to 5.
    Therefore, you will have 12TB to store your data.

  • gtdaniel
    gtdaniel Posts: 8
    First Comment Third Anniversary
     Freshman Member
    Thanks for answer!
    Problem now is on storage manager i do not have any options to manage/change something...

    Only Create or Delete...

    Searching of my problem i find something which i do not know if is relevant: "Your traditional RAID formats - 1, 5, 6, 10..all have restrictions In that you can't increase the array size beyond the size of the smallest disk"... It is corect?

  • Kim
    Kim Posts: 37  Freshman Member
    edited April 2020
    You can go to Disk group and choose the disk then you will find the option of Manage like the pic below

    After clicking Manage, you will see " Change RAID Type" like the pic below

    Then, you can change the RAID type
    Hope it helps
  • gtdaniel
    gtdaniel Posts: 8
    First Comment Third Anniversary
     Freshman Member
    I think is doable in your configuration...
    On my NAS i created volume with first option Volume and then Raid1, not with Disk Group...
    So on Disk Group i do not have anything...

  • KevinZE
    KevinZE Posts: 27  Freshman Member
    Seems you already created RAID1 on four of disks, and this config cannot change the RAID type.
    The change type is only working on the new disk which doesn't have any volume been created with this disk.
    The only way to create a RAID 5 is to delete your current Volume(RAID1) and recreate a new volume.
    Please backup all your data to another driver before you delete the volume.
  • gtdaniel
    gtdaniel Posts: 8
    First Comment Third Anniversary
     Freshman Member
    Thanks for reply!
    That seems to be solution...
    I was expected once i created a RAID1 volume with 2 hdd of 4TB and after that by extended with another 2 hdd of 4 TB, the whole array goes to 8 TB mirrored on group of 2 hdd, not to remain at 4TB, mirrored on each hdd of 4TB... My bad... Seems to be true that limitation regarding RAID1, array size not to be more than lowest disk size...

Consumer Product Help Center