NBG6616 IP address setting

Nada Posts: 6  Freshman Member
edited June 2020 in Home Router
I recently bought a second hand NBG6616 router.
I immediately updated the firmware to the latest version (8), and it seems to work ok.
My main router is at, subnet / I want the NBG6616 at, running as an access point.
I am not able to specify the IP address, it reset to everytime..which does not make any sense to me.
I have a lot of experience configuring routers, but this time I do not understand the logic.

how to handle? Who can advise me?


Accepted Solution

  • Zyxel_Freda
    Zyxel_Freda Posts: 397  Zyxel Employee
    Answer ✓
    Hi @Nada,
    Here's the change procedures from reset the NBG6616 to factory default to access it in AP mode. Please refer to below steps.
    1. Press the RESET button on the AP more than 5 seconds to set the NBG6616 back to factory default. After reset to default, please connect the WAN port (the blue port) to the modem/router which can access the Internet, and connect the NB/PC to LAN port (the yellow ports).
    2. After the NBG6616 reset to factory default, it would be in router mode and default IP is If the NBG6616 WAN port gets an IP 192.168.1.x from the router/DHCP server, the NBG6616 will change its LAN IP to as below.

    3. Connect a NB/PC on the NBG6616 LAN port to get a IP with 10.0.0.x and you can access the NBG6616 (IP via this NB/PC.
    4. After log into the NBG6616, the GUI shows easy mode and you can select to Expert Mode.

    5. Go to Maintenance> Sys OP Mode to change the Configuration Mode to Access Point Mode. When you click 'Access Point Mode', there's a warning message pop-up and after you check without problem, click OK and Apply the change.

    6. The system will restart after countdown.
    7. Go to GUI via a browser to access the NBG6616 and then you can modify the configuration of it. If you can't access the GUI, please try to use the incognito mode of the browser or clean the cache.

    If the IP of the WAN port is not 192.168.1.x/24, the default IP of NBG6616 will be in router mode, and you can access it after the NB gets the IP from NBG6616. However, the LAN DHCP server will be disabled in AP mode as the warning message, so after you changed the NBG6616 to AP mode, the NB/PC should get the IP from the router/modem and not 192.168.1.x anymore. Please modify the IP of the NB/PC as below to get the same subnet of the NBG6616 and then you can access it by

    Hope it's helpful.

All Replies

  • Greenlight
    Greenlight Posts: 57  Ally Member

    I've also seen this behavior before!! This is because the NBG is in router mode, while both WAN/LAN are in the same subnet and conflict each other. So the LAN IP address will automatically switch to

    Not sure what's your topology is, but if all network services are in the same subnet (no firewall/NAT/DHCP function is required on NBG), you can set your NBG in AP mode, and then configure the LAN port

    The setting can be found on page49 of User Guide.

    (User Guide: https://download.zyxel.com/NBG6616/user_guide/NBG6616_1.00.pdf)

  • Nada
    Nada Posts: 6  Freshman Member
    GreenLight, thanks for your quick response! I will check this later.
    How can I find out what the IP address of the AP is?
    I normally look in the main router to see what IP address is assigned, but did not work.
    This router has very abnormal behaviour.
  • Greenlight
    Greenlight Posts: 57  Ally Member

    It depends on which port is used to access the NBG. What you see on main router is NBG's WAN port address, and you can't use it to access NBG from its LAN port.

    One approach is, you can reset your NBG to default settings and use its default IP address to access it from LAN port.

  • Nada
    Nada Posts: 6  Freshman Member
    Well, the NBG6616 is in AP mode now, and I really have no clue how to connect to it.
    I have a cable directly plugged in the NBG6616 and it is fully transparant; that is fine, however I am not able to configure it anymore; the ip adress of the webinterface is hidden.
    I have resetted the router already many time and reconfigured it, but I can not get a grip on the situation..This router drives me crazy; I am close to dumping it.
    Any last ideas?

  • Zyxel_Freda
    Zyxel_Freda Posts: 397  Zyxel Employee
    edited May 2020
    Hi Nada ,

    When you configured the NBG6616 to AP mode, the interface IP of LAN is become, so you can access the AP via connecting to the LAN port and set the NB/PC to fixed IP like below.

    After setting the fixed IP, you can access the NBG6616 in AP mode and configure it.
  • Nada
    Nada Posts: 6  Freshman Member
    edited May 2020
    Thanks , but that won't work since my central DHCP server generates IP addresses between 192.168.0. 2-250 : so this will be a conflicting IP address.
    I already tried to reach and; that did not work.
    According to my main router the AP now has the IP address , so, for a brief moment, I assumed it finally worked, however did not respond at all.
    I think it is a bug in the firmware, but Zyxel does not support the router anymore.
    Reverting back to older firmware might solve the issue.

    I can use the NBG6616 as an AP now, but I am not able to change any configuration anymore (e.g. choosing a different channel)
    I also own a NBG6515 and a NBG6617; they do not show the NBG6616 either.

    The NBG6616 is a bit disappointing.

  • Greenlight
    Greenlight Posts: 57  Ally Member
    edited May 2020


    You should access not

    The address is the just the record left on your home router, which is invalid after you switching the NBG into AP Mode.

    You should change PC's interface settings like Freda said, then access the NBG with and change its configurations and IP address.

  • Nada
    Nada Posts: 6  Freshman Member
    Thanks, I resetted the router again and followed the procedure exactly as described above.
    No result at all.
    Thanks for your support, this is were it ends: I will dump this router.
  • Nada
    Nada Posts: 6  Freshman Member
    edited May 2020
    Hi Freda,

    Since you took so much time to give me this extensive procedure, I felt I should give it a last try.

    I followed your procedure without connecting it to my ISP router and I was able to configure it and switch it to AP mode. 
    The miracle happened: I could reach the AP at and I was able to change the LAN IP address to
    After a restart I connected it to the ISP router and changed the settings in my ethernet adapter back to default.
    It finally worked!

    Than I had to solve the last issue: it did not sync with the time server.
    I found out that the AP was not able use the DNS server of the ISP router;
    I configured in the AP the standard DNS ( and the time was server was found.
    This is the weirdest and most complex router I have ever seen.

    Thanks for your help; without your help this router would have been dumped now.