Zyxel Drive stopped connecting to my NAS

Csongor
Csongor Posts: 5  Freshman Member
edited June 2020 in Personal Cloud Storage
Hi All,
I am not sure what I have changed, if I have done any, but the Zyxel Drive app stopped connecting to my NAS520 at all. 
My NAS is on my latest version V5.21(AASZ.4), I restarted it, I made sure that the uPnP enabled on my router, I have removed the NAS from my myZyxelCloud account, and I am not able to add it back. I add the MAC and the SN, it tells me to press the button and when I do, the website says Device not found. 

I have no idea what got broken. I hope this is now another case of factory reset the device. All my issues I had with Zyxel was support telling me to factory reset this damn device and start over.

Csongor

#NAS_June_2020

All Replies

  • Sakura_T
    Sakura_T Posts: 101  Ally Member
    Have you checked the status In Control Panel > UPnP Port Mapping > UPnP Router?

    Also, check gateway and DNS IP address to make sure NAS can reach the internet.
  • Csongor
    Csongor Posts: 5  Freshman Member
    Yes, in the UPnP page it says that a UPnP capable router in found. And the network access is OK as well, as in the firmware upgrade page I am getting a message that the firmware is up-to-date, so it is able to check latest firmware version.
  • Scofield
    Scofield Posts: 18  Freshman Member
    Maybe you can try to re-install the myZyXELcloud-Agent app on NAS and make sure its version is 1.0.6 (latest). Then, delete the NAS that originally paired on myZyxelcloud and make sure PC and NAS is in the same LAN and pair them again. After finishing all steps, try again if the Zyxel Drive is able to connect to NAS.
  • TomMalina
    TomMalina Posts: 11  Freshman Member
    I have a similar problem, my NAS 542 is suddenly unable to connect via WebDAV or HTTP/HTTPS web interface. I can connect locally though. I have restarted the NAS and router multiple times. It seems that the NAS stopped communicating with the zyxel servers - if I log in to mycloud.zyxel.me, the IP address listed for my NAS is different then my current IP - is there a way to manually sync the NAS with zyxel servers in order to get a correct IP for the DNS I have adopted ([nasname].zyxel.me)?

    (UPnP and router Port Forwarding rules are set correctly)
  • TomMalina
    TomMalina Posts: 11  Freshman Member
    Okay, I had to reinstall the Zyxel cloud, re-pair the NAS to my email account, and set the DDNS again. 
  • Csongor
    Csongor Posts: 5  Freshman Member
    OK, I have done the same thing but it did not help.
    1) I have re-installed the cloud agent app
    2) uPnP is enabled on the router the device finds the uPnP device and I can see the external IP as well. I have NOT configured any port mappings
    3) I have added the settings in DyDNS as well, and it is active

    Still the pairing does not complete, I try to add my device manually, but as soon as I press the button on the NAS the website says "Device not found".
  • Dexter
    Dexter Posts: 108  Ally Member
    so you have already tried to factory reset but still doesn't work?
  • ElsetDesai
    ElsetDesai Posts: 1
    edited July 2020
    Hi...i think there is connection to NAS via http protocol as default port 80, and seems you have paired your NAS326 to Zyxel, but the http port would be changed by cloud if the port is the same as router's, so you have to check the UPnP setting in zyxel and enable http feature and see the port number.

    quick turn pcb assembly in usa