Multy X jumping between 20MHz and 40MHz bandwidth all the time, causing issues with some IoT devices

A_lexxA_lexx Member Posts: 9  Freshman Member
edited June 2, 2020 11:03AM in Multy WiFi System
I live in a pretty busy neighbourhood.
Running a Multy X since around a month here.

Till now, on a 2.4G band Multy has been always using 20MHz bandwidth, no issues so far.

Since a couple of days it changed to channel 9 which is a bit less busy, and started to switch to 40 MHz bandwidth intermittently. The problem is, it seems to detect conflicts, switching back to 20 MHz, then back again to 40 MHz.... It is doing it sometimes multiple times in an hour, causing disconnects to some of my IoT devices every time it does it.

Can you please improve this behavior, add some kind of hysteresis, so once it discovers a collision, it wouldn‘t again use 40 MHz bandwidth on this channel...

Or simply give a user an option to select a bandwidth manually...



#Multy_Apr_2020
«1

Comments

  • Zyxel_EricZyxel_Eric Zyxel Offical Agent Posts: 1
    Dear Sir,
    Usually, the device will not disconnect wifi when the bandwidth changed.
    But it will relate to some conditions.
    1. What model of your devices will be disconnected when the bandwidth changed?
    2. Are the devices far from the Multy? if place it closer to Multy X, will the issue still happen?
    3. When the bandwidth switch to 40MHz, will the device connected back to wifi?
    4. Multy will detect the environment, and select the best channel when it boots up, have you reboot the unit recently?
    5. Please send feedback from your Multy App, we would like to check the behavior of the Multy.

    Best Regards,
    Eric
  • A_lexxA_lexx Member Posts: 9  Freshman Member
    The affected device is Logitech Harmony Hub.

    It is placed 2 meters away from Multy with a wall inbetween, signal strength is strong.
    The device would reconnect to Multy in around 5 to 10 minutes after bandwidth changes.
    Multy has not been rebooted in weeks, although no other device would show disconnects.

    Logitech Harmony Hub would show disconnects from internet by changing the led colour to red. Every time this happens, I checked the bandwidth with a WiFi analyzer on my smartphone, and the bandwidth was jumping from 20 MHz to 40 MHz and then back again (sometimes multiple times in one hour, sometimes every few hours). This happens when a neighbor’s WiFi on channel 10 would be switched on/off (don‘t know why it‘s not on all the time like other WiFi sources). This behavior of neighbor‘s WiFi on channel 10 is the same since years, it‘s not new. Signal strength of that channel is pretty weak, it doesn‘t normally interfere with my networks, even when I‘m running WiFi on channel 9 (with my previous router I was manually running on channel 9 because it was least busy channel with least interferences from other channels).

    The location of my Logitech Harmony Hub is the same for over 7 years, also the location of the router, which has been recently replaced by a Multy. The disconnects definitively happen when Multy changes the bandwidth, they never happened with my old router.

    Multy definitively did not restart, as other devices attached per ethernet would immediately show a disconnect upon a restart of Multy, sending me a warning and logging the disconnects.
  • Zyxel_EricZyxel_Eric Zyxel Offical Agent Posts: 1
    Dear Sir,

    Please send feedback from your Multy App, and we can assist you via mail.
    Please try to reboot the Root Multy, and it will scan the wifi signal and select a better channel for your environment. and we can check if it still locates the channel 9.

    Best regards,
    Eric
  • A_lexxA_lexx Member Posts: 9  Freshman Member
    Thanks for your reply.

    A reboot wouldn‘t really be helpful. The channel 9 is actually one of the least busy channels anyway (I have up to 9 neighbors in the 2.4G band). The reason that channel 9 is least busy is actually causing the problem, on any other channel Multy wouldn‘t even try to switch to 40MHz bandwidth, would always stay at 20MHz

    And actually your suggestion doesn‘t sound very reasonable to me. It cannot be a solution to reboot the router every time it auto-selected an appropriate channel.

    Why won‘t you just allow user to select a bandwidth and/or a channel, that would be better than rebooting the unit hoping for a better match next time...

    Most of your competitors do allow those settings to be performed...
  • A_lexxA_lexx Member Posts: 9  Freshman Member
    feedback from the app sent...
  • Hi,

    I have the same issue with my Harmony HUB´s (4 peaces) constantly loosing WIFI whenever the channel bandwidth switched between 20mhz and 40mhz. There are many other WLAN´s around and this channel switch happens many times per hour. So the LED on the harmony HUB´s turn red for about 2-3 minutes many times an hour.
    I have an NWA210AX configured in Nebula cloud.

    I have now set channel bandwidth to 20mhz instead of 40mhz, and the Harmony HUB´s connection seems to be more stable. 

    I think this issue should be fixed either by lock the NWA210AX to 40mhz not switching back to 20mhz or it might be an other firmware issue.

    greets

  • tonygibbs16tonygibbs16 Member Posts: 125  Ally Member
    Hello @webkeeper

    According to page 133 of user guide at ftp://ftp.zyxel.com/NWA210AX/user_guide/ published in JUne 2020, it is possible to lock the bandwidth to 20MHz under Configuration > Object > AP Profile > Radio

    I hope that this is helpful.

    Happy New Year.

    Tony
  • webkeeperwebkeeper Member Posts: 4
    edited January 18, 2021 1:38AM
    tonygibbs16

    Because of the issue I did now lock it to 20mhz and it´s working fine with this setting.
    Using 40Mhz (locked) the issue returns that the 4 Harmony HUB´s get disconnected many times an houre because the NWA210AX still switches back to 20mhz because of many WLAN´s in the area. If i use a tool like inSSIDer I can see that even with 40mhz (locked) the NWA210AX is using only 20mhz, 10minutes later 40mhz, and this changes frequently. During the night it seems to stay stable at 40mhz maybe becaus on the other WLAN´s in the area.

    Greets
    webkeeper
  • tonygibbs16

    Because of the isses I did now lock it to 20mhz and it´s working fine with this setting.
    Using 40Mhz (locked) the issue returns that the 4 Harmony HUB´s get disconnected many times an houre because the NWA210AX still switches back to 20mhz because of many WLAN´s in the area. If i use a tool like inSSIDer I can see that even with 40mhz (locked) the NWA210AX is using only 20mhz, 10minutes later 40mhz, and this changes frequently. During the night it seems to stay stable at 40mhz maybe becaus on the other WLAN´s in the erea no traffic accures. During the day it switches many times.
    So for now, I stay with the 20mhz (locked).

    Greets
    webkeeper
  • tonygibbs16

    Because of the issue I did now lock it to 20mhz and it´s working fine with this setting.
    Using 40Mhz (locked) the issue returns that the 4 Harmony HUB´s get disconnected many times an houre because the NWA210AX still switches back to 20mhz because of many WLAN´s in the area. If i use a tool like inSSIDer I can see that even with 40mhz (locked) the NWA210AX is using only 20mhz, 10minutes later 40mhz, and this changes frequently. During the night it seems to stay stable at 40mhz maybe becaus on the other WLAN´s in the e

    Greets
    webkeeper
Sign In to comment.