NAS326. Suddenly no access possible, login data wrong

Hello community,
i have a NAS326 since 4 or 5 years and it works great (one year ago 2 new bigger Harddiscs).
Yesterday i worked on documents on the NAS, so i know that the NAS yesterday works great.
Today, i have to Work on a file, Windows says at connecting NAS: Wrong Username/Password.
Im surprised... Okay, i check the Webinterface, the same sh*t here. Wrong Password/Username. And i dont changed the Logindata, and here is nobody in my House! I use the NAS completly alone....
On the NAS works a Webserver with PHP and SQL Server (i have a WebApp for creating invoices on my NAS), also no access....
After Reboot, the same. No Access. The NAS starts without beeping, the LEDS shows no error.
By the way, the NAS have no access from Internet, only local network.
Have anyone the same problem or an idea?

All Replies

  • Sapphire23
    Sapphire23 Posts: 34
    Friend Collector
     Freshman Member
    Did you reset your NAS after this issue and see if you can access that?

    You can basically reset your NAS pressing reset button for 30 secs.
    Your data will not lose.
  • Martbert
    Martbert Posts: 3
    edited June 2021
    no i dont have reset it. However, it is strange that the NAS has reset itself, suddenly i have access with the default password 1234. The NAS has deleted all Accounts, all User and Rules. All services are deleted, no php, no mysql, but with Telnet i have rescued my Mysql database.
    For my luck, all Data on the HDDs are okay, but i have to create all users, password etc...
    I don't understand how this could happen because nobody but me has access to the device.So, for the first moment my problem is solved, but when this happens again : NAS -> Trash, and i buy an other (better) one.

  • Mijzelf
    Mijzelf Posts: 2,455
    250 Answers 1000 Comments Friend Collector Sixth Anniversary
     Guru Member
    All user settings are stored on a flash partition which is mounted on /etc/zyxel/. A factory reset basically erases this partition.
    I think this partition got corrupted somehow, resulting in that behavior. Do you know if the box rebooted between the not working and the working state? During normal operation the login credentials are not read from flash, but from a password file in ram, which is generated on boot. Maybe a power surge could destroy the flash filesystem, and reboot the box.
  • Sapphire23
    Sapphire23 Posts: 34
    Friend Collector
     Freshman Member
    Also I recommend you buying a NAS which supports RAID6(ex NAS542)

    That would give some redundancy for your data.
  • Martbert
    Martbert Posts: 3
    I hate this NAS, i really really hate this NAS. Today it happend again. I´m working with the NAS today (web developing) and it happens again. Suddenly Windows 10 shows an error, when i try to open a file on the NAS. I try to log in to the Web interface, and my username/password doesnt work, like some days beofre. The NAS says wrong username/password. But today in the morning it still works.

    I repeat, im working alone and nobody hase access to my network and my computers.
    So, i buy a QNAP 4bay NAS today.

    NEVER Zyxel NAS for me, never! And this is not a joke, i take the NAS, a hammer, and then.... You can imagine the rest of it.

  • Sapphire23
    Sapphire23 Posts: 34
    Friend Collector
     Freshman Member
    Do you use your NAS326 with latest firmware version?

    It's weird if that problem suddenly occurred after 4 years normal usage.

    I think it's a partition corruption as @Mijzelf said.
    You can reset your NAS326 to defaults and run with very basic configuration and see if it still resets to factory default.
  • e128968
    e128968 Posts: 5
    First Comment

    I have the same problem today..Nas is working fine but I can not login . Tomorrow I will reset it. Lets see what happens😮

  • ikubuf
    ikubuf Posts: 132
    5 Answers First Comment Friend Collector First Anniversary
     Ally Member

    Try accessing the NAS from a different web browser, or clear the cache and cookies on your current browser. Sometimes, an outdated browser can cause issues with accessing the NAS.

Consumer Product Help Center