luca2021 Posts: 2
edited September 14 in Security
I've been using my Zywall USG 20 for many years without any problem.
In the last few weeks it keeps rebooting, randomly, every 10/20 minutes.
No changes have been made to the firewall configuration, it's still got the original firmware.
I tried to replace the power adapter, but the problem is still there.
Any suggestions?

Adding some info. The log shows these recurrent alerts by App Watch Dog:

- ctipd.bin is dead at (date/time)
- App watch dog recover ctipd.bin dead at the 3 time

 - App watch dog stop to recover ctipd.bin. Daemon state: dead
- ctipd.bin is dead at (date/time)
- diagnostic-info is collecting now. Wait it to complete [*there are a few identical entries of this alert]

I noticed that, after these alerts, CPU usage keeps growing up to almost 100%, then the device reboots.

Best Answers

  • Zyxel_Stanley
    Zyxel_Stanley Posts: 963  Zyxel Employee
    edited September 16 Accepted Answer
    It's good to know the firmware is helpful in your case.
    In upgrade scenario, configuration will without any problem....due to all of configuration are supported in newer firmware.  But we still suggest to backup configuration before firmware upgrade.

    During firmware upgrade process, it may take full mins. Browser may already flush session before device boots up completely. So user may need to refresh browser after device booted up success.


  • I updated the firmware uploading the latest release you provided: everything seems back to normal and the log is not showing any alert! Thank you!
    P.S. I was afraid that with a firmware update I would lose all my configuration details but I found out they are untouched, very well.
    P.P.S. While updating, my browser kept showing the "Firmware upload is in progress..." progress bar in a sort of infinite loop (15 minutes had passed), but I realised the update had been done when I saw I could connect to the ZyWALL via a different browser window (leaving this comment just in case other users experience the "infinite loop", it doesn't necessarily mean it didn't work).
  • Having the exact same problem on a usg-20w and a usg-20 is there a new firmware for usg-20w ?also one flex200 having uncontrolled reboots... Ill go look at the flex200 tomorrow 
  • mMontana
    mMontana Posts: 428  Master Member
    AFAIK "latest" 3.30 P9 firmware is the WK48 lab firmware you can find at the link.

    Latest Flex 200 firmware should be 5.02(ABUI.1)C0 according to this site.

  • Ernst_Niggli
    Ernst_Niggli Posts: 1
    edited October 11
    I had exactly the same error with my old  Zywall USG 20. It would reboot every 25 min, with CPU going up to 100 % and "ctipd.bin is dead" message. The problem started after a reboot on October 10, 2021. Running firmware was 3.30BDQ5. Updating the firmware to 330BDQ.9. fixed the problem and everything is fine. Thanks for posting this fix.
  • mMontana
    mMontana Posts: 428  Master Member
    330BDQ.9 is quite old... 6 years AFAIK. WK48 is a bit more fresh, but not so much.
  • Blabababa
    Blabababa Posts: 137  Ally Member
    I think what Ernst_Niggli using is the elder eoled USG20 but not now days USG20-VPN. If it didn't reboot before, perhaps you try to re-configure your device. If problem still exist, it could be HW problem and you have to repair it (if the guy who sold you still have this model in stock) or upgrade to USG20-VPN instead
  • Folgore
    Folgore Posts: 1
    Hi @luca2021

    Which firmware version is working on your ZyWALL USG 20 ?
    The latest version of ZyWALL USG 20 is 330BDQ.9.
    We have fixed stability issues in latest release. You may have a try on it first.
    Hi had the same problem, the firmware update resolved the issue. Thanks 

Security Highlight