NAS326 firmware upgrade



  • Peppino
    Peppino Posts: 48
    First Comment Friend Collector Fifth Anniversary
     Freshman Member
    oooh, I didn't pay attention, that he received an older version... I thought he got a beta fw or something. Unfortunately mine will not allow a downgrade.
  • Mijzelf
    Mijzelf Posts: 2,216
    100 Answers 1000 Comments Friend Collector Fifth Anniversary
     Guru Member
    Yes it will, but you'll have to prepare it. Enable ssh, login as root, and execute
    echo 1 >/firmware/mnt/info/revision

    Now you can downgrade.

  • Cooper_C
    Cooper_C Posts: 13  Freshman Member
    I found all the firmware revision here:

    Downgrading was pretty straight forward.  Format a USB stick for FAT32, copy all the files from the zip file to the stick.  Power down the box and insert the stick in one of the back USB ports. Boot up the box and the firmware gets loaded.  At the above link, there is a instructional pdf.  The issue I'm having now is that admin password change isn't sticking.  The web page offers to let you change the password and is supposed to redirect to the login page, which it does not.  It just hangs.  I ssh into the box and used passwd admin to change password.  But that password seems to work only when SSHing into the box.  Not sure what the root password is.

  • Cooper_C
    Cooper_C Posts: 13  Freshman Member
    Figured out the root password and changed via the terminal. Tried adding a user via GUI, but just like changing the admin password, the add user page just hangs.
  • NathanS
    NathanS Posts: 2  Freshman Member
    Ran into something similar. I flashed 5.21 on. Web is broke, but I can ssh into the box. lsof shows http is not running, nor is anyone listening on 80/443.  I could roll back but the ftp site shows six different versions of 5.20. All I really need to do is enable/configure printing, but doing so via ssh isn't documented.
  • conan785
    conan785 Posts: 2  Freshman Member
    Same issue here.  Upgraded today and now no GUI.  There seems to be an issue with 5.21
  • manos_ir
    manos_ir Posts: 2  Freshman Member
    edited April 2018
    same issue here.....
    web page is off....
    but you can access the files by local network.
    i will try a firmware downgrade
    ZYXEL....delete plz this firmware ....
    can you explain plz how the downgrade is possible ?
    i tried to start with a usb (fat 32) with the 5.20 firmware in ,
    but still the system button is flashing (As allways after the upgrade)
    the NAS starter utility still appears the device as online with the v5.21
  • manos_ir
    manos_ir Posts: 2  Freshman Member
    edited April 2018
    problem solved :  solution here....
    it still says v5.21  but is working now.

Consumer Product Help Center