Unable to change admin password via GUI on NAS326

Options
Cooper_C
Cooper_C Posts: 13  Freshman Member
edited December 2017 in Personal Cloud Storage
When logging into box via web GUI with default password, I'm prompted to change the admin password.  After entering in new password and click apply, the change password window just hangs instead of being redirected to the login page.  Firmware is v5.20.  I get the same symptom when trying to add a user.

#NAS_December
«1

Comments

  • Rory
    Rory Posts: 120  Ally Member
    Options
    @Cooper_C

    Did you try to use other browser?
    Maybe the action be limited by browser.
  • Cooper_C
    Cooper_C Posts: 13  Freshman Member
    Options
    @Rory

    Found out something interesting with the password. If I use 15 characters the page hangs even though the hint suggest 8 or more characters. I saw a quick notice flash up about 14 characters. I used 14 characters and was taken back to the login page, but the new password didn't stick. Admin password still at default.  Changing the admin password via the terminal doesn't stick either.
  • Wiasouda
    Wiasouda Posts: 156  Master Member
    Options
    @Cooper_C
    I see your comment in other topic, you have change the root password via terminal, so I think the account information might not match between GUI and terminal.
    So you should reset your admin setting, press reset button with 1 beep, and release to try again.
    If the problem still exist, that you may need to reset all configuration with 3 beep and hold 5 sec then release the button, the process would not delete your data, but you have to enable the shard folder.
  • Cooper_C
    Cooper_C Posts: 13  Freshman Member
    Options
    @Wiasouda
    Wow! Had to do the 3 beep reset and the password stuck that time. Was able to add myself as a user as long as I didn't exceed the 14 character limit on the password. Cycled the power on the box to verify the new admin password worked and user was still there. Thanks for the tip.
  • Philip
    Philip Posts: 1
    Options
    I had same problem. I tried changing password to just 8 numbers and it worked.
  • DKarmakar
    DKarmakar Posts: 2  Freshman Member
    edited March 2020
    Options
    Hi...
    First do remove all HDisks one by one from NAS, marked all HDisks1 to 4 without fail .
    Press Reset button on Back Panel, till to 2nd Beep.
    Install NAS starter utility on you Computer to Get connect NAS through LAN with you PC directly.
    Without Hard Disks (on RAID), some features will not work, don't worry, Just Go to Reset Password, Your default password is 1234.
    After successful reset of Admin Password, Plug all Hdisks as per Array/RAID Nos.
    The Volume might be Start to Re-Sync, let it be & Don;t shutdown NAS until the Re-Sync process will be over...
    Enjoy your NAS, your Data will be as same as Previous..   

  • Chefkoch
    Chefkoch Posts: 2  Freshman Member
    Options
  • Jassu
    Jassu Posts: 5  Freshman Member
    Options
    Ok, a problem... When I press the reset-button and hear 1 beep, it won't change the password and IP back to original. I read that after releasing the button you should hear another beep - there's none.

    When login to SSH with admin account I can turn myself to root and change the password with smbpasswd - login to GUI works now. I can also try to change admin password with paswd to sync it with the one changed with smbpasswd.

    Next step: I know that I would need to change the password in GUI to get it permanent (smbpasswd change in CLI won't last through a reboot) when the system asks for old and new passwords the old password would need still to be the one with special characters, and obviously it is not working. We end up here in a error situation.

    So what now? I have lots of accounts and confs and would not want to go factory reset.
  • Mijzelf
    Mijzelf Posts: 2,645  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options
    When logged in as admin, you can change the passwords of all users without providing the current password.
    Then you can reset the current password of admin using a 'single beep' reset.

    If you don't want to use that single beep reset, you can try to edit the internal database. The user configuration is stored in /etc/zyxel/ugs_conf.db, which is a sqlite3 file. The commandline tool sqlite3 is available on the box, yet I don't know how to use it. When executing

    sqlite3 /etc/zyxel.ugs_conf.db
    .dump

    you can see the contents. The password hashes are the same as those in /etc/samba/smbpasswd. I suppose it should be able to overwrite the admin password with that from smbpasswd.

  • Jassu
    Jassu Posts: 5  Freshman Member
    Options
    You can change all the user passwords without knowing the old one, except the preinstalled admin-users. For that you need to know the old one.

    Even after reboot, using other admin account (I enabled admin-rights for another user) the "single beep reset" is still not working - so it seems that probably only way is to tweak the db?

    Damn Zyxel, how the h*ll you are making these kind of updates that break things?

Consumer Product Help Center