Plex for NAS326

Emerald Dragon
Emerald Dragon Posts: 118  Ally Member
How do I install Plex for NAS326?

Accepted Solution

  • Mijzelf
    Mijzelf Posts: 1,690  Guru Member
    edited April 2020 Accepted Answer
    1st, Right-click downloaded web_prefix (no extension) uploaded to admin folder (NAS326)

    Step 1

    Download the file web_prefix, and put it in the directory \\<NAS>\admin\zy-pkgs\


    NAS5xx, NAS326

    (Firmware 5.10+ only) On this NAS there is no subdirectory zy-pkgs in \\<NAS>\admin\. Just add it.
«134

All Replies

  • Mijzelf
    Mijzelf Posts: 1,690  Guru Member
    First install MetaRepository.
    Scroll down for instructions.

  • Emerald Dragon
    Emerald Dragon Posts: 118  Ally Member
    I followed the instruction from the link, but it didn't work. Not sure what I did wrong.

    1st, Right-click downloaded web_prefix (no extension) uploaded to admin folder (NAS326)

    2nd, On the web interface desktop, open the 'App Centre'. Goto 'Browse->All Apps'. Now there is a cycle icon on the page. Push it. and nothing happens.

    I also downloaded MetaRepository_20181001_arm_015.zpkg and uploaded it to the admin folder and tried to do it again and nothing happens either. Maybe, I am missing something here.  Can you elaborate on what I did wrong here? Thanks.

  • Emerald Dragon
    Emerald Dragon Posts: 118  Ally Member
    Oh, DUH! I got it now. A little confused at first. Thanks, @Mijzelf for your help.
  • Emerald Dragon
    Emerald Dragon Posts: 118  Ally Member
    WOW! It also added a whole bunches of other nice extras add-in too. Cool B)B)B)<3<3<3
  • erik88
    erik88 Posts: 1
    hello everyone, I also have the same problem as many.
    I currently have the latest version installed (V5.21) on zyxel 326.
    I uploaded the MetaRepository_20181001_arm_015 file and I renamed it 
    web_prefix
    (without any extension) and as per instructions I added it to
    the zy-pkgs folder
    that I had to create. Then I went inside the App Center / browse / all applications but
    nothing appears after 2 refreshes (but a window appears with the message:
    Download list Fail). Please can you tell me where I'm wrong? thank you



  • SaintVII
    SaintVII Posts: 3  Freshman Member
    Thank you Mijzelf !! Great instructions... however I have a question after you get the plex server installed and running... When choosing a folder to point to in plex, the file directory will not allow me to go back further than "/firmware/mnt/" which I can't seem to locate anywhere on the local... is this a location on another server elsewhere? Any work around to get it to point to a local folder on the NAS326?
  • SaintVII
    SaintVII Posts: 3  Freshman Member
    Oh wait.... I just found the location... it was under "/etc/zyxel/storage/sysvol"
    Thanks again!! 
  • SaintVII
    SaintVII Posts: 3  Freshman Member
    Okay so after creating the library again on the NAS326 for plex, How can I migrate all of the metadata and systems settings from old plex server over to the new plex server on the NAS326? Because as of right now, it is still showing the "Master" of plex, as my old computer/server.

    Where is the location of all of the plex files on the NAS326? So that I can move/transfer all of the data from old machine to the new server NAS326...???
  • Mijzelf
    Mijzelf Posts: 1,690  Guru Member
    Where is the location of all of the plex files on the NAS326?
    You can find the installation in /i-data/sysvol/.PKG/PlexMediaServer/share/PlexMediaServer/
    I can't answer the other questions. I'm not a Plex user myself.