NAS 542 DNS Disconnect/Connect Problem

Options
Hi there! 
I got a problem with my 542 NAS. It's super strange to me and I registered here in this forum because I'm out of ideas.
Main problem was that my 542 NAS had no internet connection whatsoever. Every other device, let it be wlan or lan, had an inet connection. Simply the NAS don't.
" Okay then open the needed ports for communication" 
I did! 20/21/443/5000/5001/80...all of them.
Nothing happened.
Okay I thought to my self.. let's see how far the ping goes. 
I can ping my router with the internal ping tester just fine. Over ssh no problem aswell. 4 out, 4 in, 0 package loss! 
But!! If I try pinging outside my home network (e.g. 8.8.8.8) I get an error.
NOW comes the strange part which confuses me a lot.
When I'm changing the default primary dns of the NAS to e.g. 8.8.8.8 nothing changes ... If I then enter a secondary dns e.g. 1.1.1.1 the NAS has an connection!!! It works...
BUT! only for a couple of seconds. It lastet the longest with almost a minute. Then the connection cuts down.
If I then go back to the NAS dns settings and change NOTHING AT ALL just hit the apply button a let the waiting wheel spin...the NAS has a connection again for again a short period of time (max. 56 sec.).
I need help please! 
Information for my system:
Fritzbox 6490 192.178.168.1 dhcp
NAS static IP given from Fritzbox with 192.178.168.26

Thank you in advance !

Gz flo
«1

All Replies

  • Mijzelf
    Mijzelf Posts: 2,639  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options
    That doesn't sound like a dns problem. More a gateway problem. Are you sure you specified the right gateway? That should be your router.


  • Batou
    Batou Posts: 101  Ally Member
    Options
    You should try ping the DNS on your router to check if it's working.
    Like @Mijzelf said, maybe there is mis-config of gateway setting.
  • angelica
    Options

    I'm resurrecting this because my NAS326 is doing the exact same thing. Reapply DNS settings: get Internet access for maybe 30 seconds, during which time it can ping external sites, find the UPnP router etc.

    The rest of the time: pinging the router's fine, pinging externally isn't.

    This may be missing an obvious piece of tech literacy, but: the replies here say to check gateway settings. What gateway settings, where? I'm going round in circles and yesterday I managed to take out both the NAS and partially my entire Internet trying to fix this.

  • Mijzelf
    Mijzelf Posts: 2,639  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    If you can ping the router, but can't ping externally, than for some reason the NAS has forgotten it's gateway (which you can see with the 'route' command) or for some other reason the router rejects to route for the NAS. (Maybe the firewall has a max connections per device, which overflows by some call home construction?)

    Anyway the difference in output of

    route
    cat /etc/resolv.conf
    ifconfig
    

    in that 30 seconds and later might tell more.

  • angelica
    Options

    Thank you, but forgive me - I'm not a network admin but just a home user, and I'm looking at the Web GUI, and can't see any terminal where I'd enter the above. Unless you mean in command prompt, which allows a route command but not cat or ifconfig?

  • Mijzelf
    Mijzelf Posts: 2,639  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    You can get a terminal by enabling the ssh server on the NAS, (somewhere in network settings, when I remember well), and type 'ssh admin@<ip-of-nas>' in a command prompt.

  • angelica
    Options

    Thank you! Here's the full result - the first lot is before applying, the second is after (and I checked it pinged externally before and after running the second lot).

    It seems to create a default line above the "Gateway: *" line with a gateway of 192.168.1.1, which is my router's address, during that 30 seconds.

  • angelica
    Options

    Waittttt, turning on the SSL changed the NAS address to have a :392 at the end, and somehow this has made it work? I'm not sure what the status was when I ran the first route above - I should've checked, but it's been consistent every time I've looked - but it's now accessing the Internet seemingly fine

  • Mijzelf
    Mijzelf Posts: 2,639  Guru Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    So indeed your NAS looses it's default gateway. The 2nd 'route' output shows a default gateway, the 1st one doesn't.

    A default gateway is the address which is used to send packages to with a destination outside the current local network(s). So without it, the NAS simply doesn't know where to send this packages to, and will drop them.

    Question is, why does it disappear? I can think of two reasons:

    • For some reason the DHCP server in the network sends an update packet where the default gateway is empty.
    • A bug in the firmware, which resets the gateway on a watchdog action after a network reset (Apply from the webinterface. I suppose there is no dedicated DNS apply).

    If the first one is true, it might help to reboot your router, as virtually always that is your DHCP server. If the second is true, what is the trigger? A failed call home? It's not common sense to reset a gateway when it doesn't seem to work. There could be a number of reasons for that, an disabling the gateway doesn't solve that.

    find the UPnP router etc.

    Are you using UPnP? Have you tried if disabling it solves this issue?

    Waittttt, turning on the SSL changed the NAS address to have a :392

    An IPv6 address I suppose? I don't see that address in your ifconfig output. And you mean ssh?

    There might be a connection between a disappearing default gateway and a 'new' IPv6 address. The most used way to distribute IPv6 addresses is that the router broadcasts it's IPv6 subnet. And every device in the network just chooses randomly an address in it (well, not really random). A malformed (or misunderstood) broadcast packet (SLAAC) might do strange things to the network settings. In your ifconfig output there is no public IPv6 address. If there is one now (an address not starting with fe80) than the NAS has started to either receive (and process) SLAAC or IPv6 DHCP packets where it didn't do before.

    But I don't see a connection with ssh.

  • angelica
    Options

    Sorry yes, I meant SSH. Not an IPv6 address, no: a, er, port number, if I have it right? As in it used to be http://192.168.1.100/ or http://nas326/ locally and it instead changed to http://192.168.1.100:392/ or http//nas326:392 after turning SSH on. Or perhaps after running one of the above commands?

    I'm not sure what's happened, but anyway it does suddenly seem to connect to the Internet okay now. And weirdly under Network Interface, it has a field for Gateway that it didn't have before. This after seemingly not having connected since early this year, and the router's been reset plenty in that time.

    And yes, UPnP was already turned on on the router and I think always has been. What I was trying to do was connect it so that I could share files online. And MyZyxelCloud doesn't seem to be working properly but I do seem to have managed to find a clumsy way to do that so I think we're good! Thank you for yr help, even if likely neither of us will know exactly what the problem was or how it was solved.

Consumer Product Help Center