NR5101 Bridge/Router Mode Greyed Out

Options

I'd like to configure my NR5101 in Bridge mode (not IP Passthrough). According to the manual there's a "Mode" drop-down in Network Setting > Broadband > Add or Edit New WAN Interface that selects between "Routing" and "Bridge". I see that drop-down, but it is set to "Routing" and greyed out. I've tried updating to latest firmware and factory resetting the modem.

All Replies

  • Bob_C
    Bob_C Posts: 174  Zyxel Employee
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    Hi adogontheinternet,

    May I know the reason for setting bridge mode on the NR5101?

    My understanding is, if you connect a Wi-Fi AP to the NR5101 and enable IP passthrough on the NR5101, the NR5101 will forward the IP address that it acquires from the Internet service provider to the Wi-Fi AP. Does this meet your requirement?

    Regards,

    Bob

  • adogontheinternet
    Options

    It doesn't meet my requirements. I purchased the modem specifically because I saw claims on the web that it supported proper bridge mode and the greyed out option suggests that perhaps it did in earlier firmware versions. Empirically, IP passthrough behaves significantly differently to a real bridge mode, assigning an adjacent IP address (that it can't have any ownership of or right to assign) to the modem and routing at layer 3 rather than forwarding at layer 2. The details of how it does this are of course completely undocumented and vendor-specific. My situation is already complex enough, with a mobile provider assigning a dynamic IPv4 address behind CGNAT and not supporting IPv6. Having this device getting involved at layer 3 is a complication I just don't need. All I want is a modem.

    I currently have a problem that may or may not be related to this IP passthrough thing. The modem becomes completely unresponsive every day at 12 noon and again at 12 midnight for around 15 minutes. It doesn't respond to pings during this time, and tcpdump -e on my router shows no ethernet traffic at all coming from the modem. It comes back to life again after 15 minutes or if manually powered off and on. My attempts to diagnose this have been severely hampered by the fact that logging doesn't work - see my other question:

    I'm slowly and reluctantly being forced to the conclusion that this device, which I've spend over 300 pounds on, is a bit rubbish.

  • Noddy
    Noddy Posts: 56  Ally Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    @adogontheinternet I haven't got my NR5101 powered up at the moment, but when you say…

    "According to the manual there's a "Mode" drop-down in Network Setting > Broadband > Add or Edit New WAN Interface that selects between "Routing" and "Bridge". I see that drop-down, but it is set to "Routing" and greyed out."

    Was that greyed out whilst editing a pre-existing WAN interface? Just wondering if adding a new WAN interface lets you then unlock that option?

    I see what you mean though from the user guide (pg. 102) - https://download.zyxel.com/NR5101/user_guide/NR5101_Version%204.40%20Ed%204.pdf

    I'm just wondering why IP Passthrough isn't what you need? I'm not 100% technical. But in the past I used the NR5101 with a Smarty MVNO SIM, Three UK SIM and EE SIM. I would utilise IP Passthrough through to allow it through to my (now defunct setup) Asus XT12 mesh nodes.

    Is this the firmware you are on? V1.00(ABVC.6)C1.

    I don't get why the logs aren't working either. Just checked my FWA710 and it is set as you say and the logs entries are showing. 🤔

  • adogontheinternet
    Options

    I was on V1.00(ABVC.9)D0 but have downgraded to V1.00(ABVC.6)C1 which has resolved the logging issue. Thanks Noddy for pinging me on another message that alerted me to that.

    Unfortunately, the downgrade didn't enable the proper bridge mode option and the logging has confirmed my worst fears. "Cellular IP Passthrough" really will not do.

    What is happening is that the NR5101 is obtaining an IP from my ISP via DCHP and issuing it (that same IP) to my router via DHCP. Unfortunately, the NR5101 appears to be making no attempt to line up the expiry times on these leases. The NR5101's lease expires and it gets a new IP address, after which the router is stuck with the wrong IP address until its own lease expires, during which time the whole thing is kaput.

    There are details in the DHCP activity here that I could improve to reduce the amount of time this will not be working. (I could force my DHCP client to always use broadcast rather than unicast for requests, and I could move to a better DHCP client than the one I'm using, which doesn't seem to handle NACKs properly.) However, these would only reduce the time. I would always be stuck with a period of several minutes of dead time a couple of times a day (thanks to my shonky ISP, the only option I have) because there is nothing to trigger my DHCP client to requests a new lease when the NR5101's lease expires. This is inherent to the DHCP protocol - it's a pull rather than push model. Even if the NR5101 were to line up the expiry times better there would be at least a small outage at the changeover.

    Probably the best I can do, if there is really is no proper bridge mode on this device, will be to have a script on the router that continually pings the NR5101 and forces a DHCP renew if the ping fails - sellotape and bits of string.

    This would not be a problem with a true bridge mode. There would only be one DHCP negotiation, between my router and the ISP as God intended.

    I really am upset about this. I bought this modem specifically for its bridge mode, which is shown in the manual. IP Passthrough is not an acceptable substitute.

Consumer Product Help Center