LTE5388-M804 loses network after some time

Options
1235»

All Replies

  • RobTheNetworkGuy
    RobTheNetworkGuy Posts: 14  Freshman Member
    10 Comments Friend Collector
    Options

    Excellent work! This is much better than my brute force Web UI approach. I'll give a try and reports back.

  • JeanFrancois
    JeanFrancois Posts: 45  Freshman Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    v1.0.1: script updated to handle low SNR and use RX vs. TX for detection 😂

  • JeanFrancois
    JeanFrancois Posts: 45  Freshman Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    I've tested today with a VM, and aparently "expect" package can be installed on pfSense without other dependency (of course you must enable Freebsd packages). It sounds a reasonnable risk to add this single unofficial package, at least it won't require a thousand other packages to be installed on the firewall. Of course, it could be a better solution to audit the code and/or ask Netgate to add the package in a future release.

  • JeanFrancois
    JeanFrancois Posts: 45  Freshman Member
    First Anniversary 10 Comments Friend Collector First Answer
    edited April 2023
    Options

    v1.0.3: fixes to handle several situations like wwan0 interface missing, connection Down…

    Remember to adapt thresholds depending on whether you have enabled IPv6 or not, because there is much less data received in pure IPv4 with a non-routable address, and of course to modify your IPv4 address and SSH passsword. The script requires "expect" command, available on MacOS (natively), FreeBSD (including pfSense if you enable FreeBSD packages), Linux. Several ports also exist for Windows. For LTE5388-M804 and LTE5398-904.

  • fabriba
    fabriba Posts: 18  Freshman Member
    10 Comments Friend Collector
    Options

    any updates on this from zyxel?

    without a firmware fix we are left with the temptation to jailbreak the device and login with supervisor user and do it ourselves, but frankly it would be nice to see a fix given one was ready made by JeanFrancois

  • JeanFrancois
    JeanFrancois Posts: 45  Freshman Member
    First Anniversary 10 Comments Friend Collector First Answer
    Options

    To whom it may concern, v1.0.5 with minor improvements.

    As always, remember to adapt thresholds depending on whether you have enabled IPv6 or not, because there is much less data received in pure IPv4 with a non-routable address, and of course to modify your IPv4 address and SSH passsword. Don't forget to save your configuration with zycli save_default save otherwise reboot will lead to reset to the factory settings! Use at your own risk.

  • fabriba
    fabriba Posts: 18  Freshman Member
    10 Comments Friend Collector
    edited July 2023
    Options

    I received a first beta version of a bugfix yesterday, but within ~30hrs the problem presented again.

    Good news is, a fix seems to be on the way.

    I wouldn't know what the fix is about exactly, but during the lifespan of my support ticket there's been a lot of talking about a "watchdog" which should have to do with the idea on this thread.

  • Rcatech
    Rcatech Posts: 10  Freshman Member
    10 Comments Friend Collector
    edited December 2023
    Options

    same issue with router LTE5398-M904, firmware V1.00(ABQV.4)C0 (28 oct.2023)

    and LTE module firmware EG18EAPAR01A12M4G_01.001.01.001

    I have lost all hope that the Zyxel development team can (or actually want to) fix the issue.

    (tested in Italy with Vodafone, Iliad, Postemobile, Wind3, HoMobile, Fastweb, VeryMobile)

Consumer Product Help Center