New mirror for nas-central.org

124

Comments

  • Diskutant
    Diskutant Posts: 7  Freshman Member
    Seems like the output is the same. The shell was quiet but the log file: https://pastebin.com/6ZCE4PJN

    I copied the smb.conf and removed the deprecated and unknown parameters and changed the 
    ZyXELSambaReplacement.conf to include that file. Then the log file shows only 

    [2020/12/02 18:21:49.562775,  0] ../../source3/smbd/server.c:1782(main)
      smbd version 4.12.5 started.
      Copyright Andrew Tridgell and the Samba Team 1992-2020

    but it doesn't seem to run.

     ps | grep smbd
    14800 root      2492 S    grep smbd


  • Mijzelf
    Mijzelf Posts: 1,985  Guru Member
    You can try a higher log level with '-d 2' or something like that. From the man page:
    Levels above 1 will generate considerable amounts of log data, and should only be used when investigating a problem. Levels above 3 are designed for use only by developers and generate HUGE amounts of log data, most of which is extremely cryptic.

  • Diskutant
    Diskutant Posts: 7  Freshman Member
    edited December 2020
    Now the log file shows this:

    [2020/12/03 17:20:00.164004,  0] ../../source3/smbd/server.c:1782(main)
      smbd version 4.12.5 started.
      Copyright Andrew Tridgell and the Samba Team 1992-2020
    [2020/12/03 17:20:00.259279,  2] ../../source3/smbd/server.c:1786(main)
      uid=0 gid=0 euid=0 egid=0
    [2020/12/03 17:20:00.259656,  2] ../../source3/param/loadparm.c:322(max_open_files)
      rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)


    I tried with Level 9
    It shows a lot of stuff, at the end its "doing parameter" for all the smb.conf parameters and after that:

    [2020/12/03 17:23:51.950786,  4] ../../source3/param/loadparm.c:3974(lp_load_ex)
      pm_process() returned Yes
    [2020/12/03 17:23:51.951006,  7] ../../source3/param/loadparm.c:4309(lp_servicenumber)
      lp_servicenumber: couldn't find homes
    [2020/12/03 17:23:51.951250,  4] ../../source3/smbd/sec_ctx.c:174(get_current_groups)
      get_current_groups: user is in 1 groups: 0



    What package do I need to install for entware ssh server to get my admin homedir back?
    Are the randomtools and tweaks gone with the new entware? I can't find those using "opkg list"

  • Mijzelf
    Mijzelf Posts: 1,985  Guru Member
    About smbd, I'm out of ideas. If the daemon stops running without telling why in the logfile, it's over.
    What package do I need to install for entware ssh server to get my admin homedir back?
    Don't know. If you are using the Entware ssh server, and /opt/etc/passwd is not a symlink, you should edit it to enter the right homedir for admin.
    If you are using the firmware ssh server, the firmware should change that homedir in /etc/passwd. If it doesn't, try disabling packages and reboot to see which one is the problem.
    Are the randomtools and tweaks gone with the new entware? I can't find those using "opkg list"
    Entware has nothing to do with RandomTools and Tweaks. Those should be available in the firmware package manager, if MetaRepository is installed and running.

  • ehorher
    ehorher Posts: 5
    Hello everybody, I´m just wondering if I can install a Web browser client in my NSA325v2, to access a web page directly from the NAS, to download anything there instead to download in the computer and transfer to the NAS. I really appreciate any help on this...thanks a lot !!!
  • Mijzelf
    Mijzelf Posts: 1,985  Guru Member
    The NAS has by default 2 http clients, wget and curl. If you know the url of the file you want to download, you can

    wget URL

    or

    curl URL > <desired filename>
  • ehorher
    ehorher Posts: 5
    Hi Mijzelf! thanks a lot for your quick answer. Thing is that the file is stored on google drive, I tried to do the download with wget:

               => `uc?id=19HNrL6PgLD8VjedBFRshbNMVDyRJ6j_3&;export=download'
    Resolving drive.google.com... 142.250.64.174
    Connecting to drive.google.com[142.250.64.174]:443... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: unspecified [text/html]

        [ <=>                                                                                                                                                                ] 3,350         --.--K/s             

    12:38:05 (2.18 MB/s) - `uc?id=19HNrL6PgLD8VjedBFRshbNMVDyRJ6j_3&;export=download' saved [3350]

    And it´s just downloaded a small file:

    -rw-r--r--  1 root   root 3.3K Jan 22 17:38 'uc?id=19HNrL6PgLD8VjedBFRshbNMVDyRJ6j_3&;export=download'

    This is why I´m looking for a browser that can be installed on the NAS and using it with a X11 client on my laptop....

    Again, thanks a lot for your help on this....

  • Mijzelf
    Mijzelf Posts: 1,985  Guru Member
    You can have a look inside that downloaded file, it is possible that is contains a redirection to the 'real' URL.

    About running a webbrowser, I think you are out of luck. You can install something like Lynx, I think that will be available as Entware-ng or ffp package, but that won't be able to download something from google drive, as it lacks a javascript engine.
    Your box runs an armv5 processor. I don't think any recent javascript engine will run on that. Both Chromium and Firefox dropped Armv5 support something like 10 years ago. And I don't think you can access google drive with a 10 years old browser.

  • ehorher
    ehorher Posts: 5
    Thanks Mijzelf, I´m thinking to replace my old NSA325v2, so, what is your opinion to replace it? 
    Please let me know.
  • Mijzelf
    Mijzelf Posts: 1,985  Guru Member
    And that new NAS should be capable to run a modern webbrowser? In that case you need a NAS running some distro which is also available for the desktop, as nobody compiles a browser for a headless system.
    And it should be at least an Armv7, or an x86. (If I omit the more diverging archs). An Armv8 with enough memory running Debian would be fine. A Helios 64 would be great, unfortunately it's no longer for sale.

    There are enough Armv8 NASses out there, Synology has several, but I doubt you can install Debian on them. And although you in theory can compile everything yourself, it won't be easy. If I run 'apt install firefox-esr' on my headless Debian server, I get:

    The following NEW packages will be installed:
      adwaita-icon-theme dbus-user-session dconf-gsettings-backend dconf-service firefox-esr fontconfig glib-networking glib-networking-common glib-networking-services
      gsettings-desktop-schemas gtk-update-icon-cache hicolor-icon-theme libatk-bridge2.0-0 libatk1.0-0 libatk1.0-data libatspi2.0-0 libcairo-gobject2 libcairo2
      libcolord2 libcroco3 libdatrie1 libdbus-glib-1-2 libdconf1 libepoxy0 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common libgraphite2-3 libgtk-3-0 libgtk-3-common
      libharfbuzz0b libjson-glib-1.0-0 libjson-glib-1.0-common libpango-1.0-0 libpangocairo-1.0-0 libpangoft2-1.0-0 libpixman-1-0 libproxy1v5 librest-0.7-0 librsvg2-2
      librsvg2-common libsoup-gnome2.4-1 libsoup2.4-1 libthai-data libthai0 libwayland-client0 libwayland-cursor0 libwayland-egl1 libx11-xcb1 libxcb-render0 libxcb-shm0
      libxcomposite1 libxdamage1 libxi6 libxinerama1 libxkbcommon0 libxrandr2 shared-mime-info
    0 upgraded, 57 newly installed, 0 to remove and 15 not upgraded.
    Need to get 78.6 MB of archives.
    After this operation, 294 MB of additional disk space will be used.

    All these packages are not needed for normal NAS functionality, and so they won't be available on a typical NAS OS.

    Can't you just download the file to a share?



Consumer Product Help Center