VMG3925-B10B drops 5GHz wireless several times a day - HELP!

TJcph
TJcph Posts: 2  Freshman Member
edited September 2018 in Smart Home Product
Hi guys,
Turning to this forum as my last resort.

I recently got fiber installed and along came the Zyxel VMG3925-B10B router.
I registered both a 2.4 and a 5GHz wireless through the router without problems. I used the same password for the two networks.

But, for three weeks now, my 5GHz wireless keeps on failing several times a day, so that I have to restart the modem in order for it to work again. This is not popular in a family of 4.

The SSID is showing but when I try and access it via an iPhone for example, is says "Wrong password" even though it is the correct one. I can tell when the 5GHz is failing as the internet connection is inaccessible. Sometimes the SSID is not even visible as a wireless network.

The 2.4 GHz is not affected at all, which is very strange. But I want the speed of the 5GHz for a couple of my devices.

My provider has been abolute sh*it in providing a solution as they have never encountered the problem they say. Evrything looks good at their central. They are having me try to turn off some of my older devices like an iPad 1st gen to see if that helps, but it hasn't.

Router has latest firmware and everything - I've checked. And I also recived a new one, because this was also happening on the previous Zyxel router (same model).

I previously had a Sagemcom Fast 3890V2 router from my previous provider through a coax connection without any wireless problems at all, which makes me think it has something to do with the new hardware.

Do I need to configure something in the router, missing a check mark or something - I am at a loss here!

Sorry for lengthy post - but any help will be greatly appreciated.

Thanks.

TJcph
#CPE_Aug
«1345678

Comments

  • AAAAL
    AAAAL Posts: 125  Ally Member

    Hi TJcph,

    May I know it need to take how long for this “5G WLAN not be associated” happened ?

    Is there a lot of traffic generated during this period ? How many clients connected to the router at that time ?

  • TJcph
    TJcph Posts: 2  Freshman Member
    Hi AAAAL,
    This problem has been there right from the start when I swithched to fiber and the new Zyxel- hardware, whihc is 3 weeks now. I am on my second Zyxel VMG3925-B10B router.

    I don't know if it is a lot of traffic. I think my household is similar to others.

    Usually there are 3 mobile phones connected to the wifi, My son's computer, 2-3 iPads and then an occasional PS4 and Apple TV are also on the wifi when it fails. Can also be fewer and more. One iPhone, the PS4 and my son's computer are the only ones on the 5GHz. The rest are on 2.4.

    In the router menu is says that I should be able to connect 32 devices to each of the networks if I am not mistaken.

    Any suggestions?

    /TJcph


  • Zyxel_Support_CPE
    Zyxel_Support_CPE Posts: 187  Zyxel Employee
    Hi TJcph,

    In order to provide you with a better assistance, we contacted you through private message to get more information, please check your message box.


  • Ptillegr
    Ptillegr Posts: 1
    edited December 2018
    I got fiber installed with the zyxel vmg3925-b10b router delivered as part of the installation. First few days both 2.4 and 5ghz worked fine. Now 5ghz is very unstable if at all available. If am close to router with device, have max 3-4 devices connected, 2.4 ghz channel works fine. Could it be a patch needed in the router software?
    @Zyxel_Support_CPE please post any guidance here, not just in PM. It seems to be a general problem with the router?
  • Zyxel_Support_CPE
    Zyxel_Support_CPE Posts: 187  Zyxel Employee

    Hi Ptillegr,

    Can you describe more detail “5ghz is very unstable“?

    WLAN client can connect via 5G SSID, but sometimes traffic will be drop? Or 5G SSID disappear? Or other situation?

    And please also share the firmwave version of your device.


  • Hi. I have the exact same problem as post #1, with the exact same router. Did you figure our What the problem was, or Can someone fra Zyxel please PM me? 

    Best regard
    michael 
  • Zyxel_Support_CPE
    Zyxel_Support_CPE Posts: 187  Zyxel Employee
    Hi Guldsteen,

    May I have the firmware version of your device? We will have generic fw to improve 5G wifi part, the schedule is 2019/3/E. Let me know your firmwave versoin first and then I will let you know if new version is suitable for your device or not. 

  • Toxiaxia
    Toxiaxia Posts: 3  Freshman Member
    Dear Zyxel support, 

    i have the exact same issue and my router came with Firmware Version: V5.13(AAVF.11)C0_20180409B.

    i have also downloaded V5.13(AAVF.12)C0 and tried to upgrade the FW, but it always rollback to the old FW version after 2-3 reboots.

    Even during the short period the router running with the newer FW, AAVF.12, the 5G WiFi still disappeared after 3-4 hours regardless whether I logged on to 5G network or not. That’s also the reason I have to reboot the router to bring 5G WiFi back, which caused the FW rollback after 2-3 reboots. Really annoying!

    meanwhile, 2.4G WiFi works just fine.

    can you please also send a new FW to me?

    thanks in advance!
    Happy new year btw!

    br, Xia
  • Zyxel_Support_CPE
    Zyxel_Support_CPE Posts: 187  Zyxel Employee

    Hi Toxiaxia,

     

    The latest generic fw is V5.13(AAVF.12)C0, we expect to have next release on March/E.

    You mention device will rollback to older version after 2-3 reboot. So did you try to reset your device after upgrading to V5.13(AAVF.12)C0? I am not sure if you ISP is control it keeps in older version or not, can you please ask your ISP for this?


  • SteveRouter
    SteveRouter Posts: 2  Freshman Member
    Any news for a fix for this? I updated from the old V5.11(AAVF.3)C0 firmware to V5.13(AAVF.12)C0 and have the same issue with 5Ghz wifi either losing SSID or showing it but not connecting after a few hours.

    I rolled back to the earliest firmware still available and have the same issue. Is it possible to allow access the the older V5.11(AAVF.3) firmware which was more stable?
Sign In to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click on this button!